Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Images semi translucent, slow to upload, error

edited November -1 in Troubleshooting
I sometimes wonder if we're the only ones with issues, or just the only ones posting about them. Sorry for so many in the past week!
Since our upgrade to 1.2 we have a some new problems with images:
They're basically translucent/very pale, much slower to upload (about 5 minutes for a small image, where it used to take a second or two), and we get this error on our media page: Warning: array_values() expects parameter 1 to be array, null given in /home/public_html/Museum/Coll/app/lib/ca/Attributes/Values/TextAttributeValue.php on line 254 (a similar error occurs in the logs, but just the one).
I suspect the three issues are related, but really have no idea. None of our settings have changed. (Old images are fine, it's just new ones that have this translucent problem. When they're opened in the viewer (as opposed to just seeing the thumbnail in other pages), the problem is less pronounced.)

[attachment=9192,468] [attachment=9192,469]

Comments

  • Hi Kaia,

    No problem asking questions here! It's good that you're asking them publicly so others can benefit. We get a lot of direct email queries which is kind of a shame since no one gets to refer to them other than the original author.

    In any event, I think the source of a number of your issues is your host. This translucency issue is an example of this. What image processing plugin are you using? If you're not sure, try going to the "Manage" menu and select "Configuration Check" under "Administrate"

    We've seen some recent versions of ImageMagick that exhibit this kind of problem, as well as odd color shifts. We've also seen ImageMagick installs configured with lcms (color management software) that do this sort of thing. Switching to an older version of ImageMagick, or one without lcms support can address it. If you're not running ImageMagick, then letting me know what you are running will help greatly to narrow down the possible causes.

    seth
  • It appears we're using Imagick. (Also, I don't think there were any changes to anything on our server other than the upgrade to 1.2.)

    [attachment=9778,470]
  • Hmm. Try opening up app.conf and setting the dont_use_imagick setting to a non-zero value. Then try uploading the problem files. Anything different?
  • Well, we've switched to Dreamhost and no longer have this problem. If it would be helpful, I can try the dont_use_imagick setting on the old install to help identify if this is a more prevalent problem. (On Dreamhost we're using ImageMagick.)
  • Yes, please. I'd be very interested to know what the root cause of this is.
  • Hi. I'm having the same (or at lease similar) problem.
    The uploaded images have really pale colours. 
    Anyway, it seems it is a visualization problem: the file (when downloaded back), is the same as the uploaded one.

    Any suggestion to fix that? Attached is my configuration.

    Thank you!



  • Based upon your configuration I'd say the problem is Imagick and the version of ImageMagick you have installed. Some of the older ImageMagicks have color management bugs that cause very pronounced color shifts. Try upgrading the install of ImageMagick or (preferably) switch to GraphicsMagick and the gmagick PHP extension.

    seth
  • Seth,

    I was experiencing the same issue.

    Switched from ImageMagick to GraphicsMagick and the issue has resolved.

    Thanks, JTW
Sign In or Register to comment.