Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

[Providence] Suddenly slow in image upload speed

Zoe
edited July 10 in Troubleshooting
I have asked the question in chat room, but the issue may need more information in detail such as configure files to support, so I moved it here. Please ignore the question in chat room. I attached app.conf and Configuration Check screenshots for reference. Thank you very much!

Problem:
It is an issue regarding image upload speed. 
In my server setting, images will be processed using Graphicsmagick and uploaded to a network drive. Everything was perfect until 3 weeks ago, the image upload speed suddenly slow down. Until 16 June, providence could process 1 image in 0.5 minutes, but on 19 June, needed 4 minutes for same size of image. The change of speed was sudden. 
And in Configuration Check, it said some of my network folders are not writable by webserver, but checked that they are writable. I don't know if it is the reason of slow upload speed.

Steps taken to troubleshooting:
  1. The issue appears in both batch media upload and media upload section in individual record. Task queue is disabled in all cases.
  2. I tried to upload other types of media. Although upload image is slow, upload movie and pdf is fast.
  3. Change the upload destination to local drive, the upload speed of image is fast. The connection between server and network drive should be normal, as I could upload movie and pdf to network drive very fast. 
  4. Tried to use GD instead of Graphicsmagick, the speed still very slow. I tried my effort to use Imagemagick or Gmagick Imagick, but never get them working in windows.
  5. One more thing I noticed is that if it is in normal speed, the gm.exe will appear sticking on the task manager until 1 photo is done. But now the gm.exe keep open and close, wait for some time then re-open.

Version of the software:
Providence: 1.6.3
Server: Windows Server 2012 R2
Apache: 2.4
MySQL: 5.7
PHP 7.0
Graphicsmagick: 1.3


759 x 387 - 67K
761 x 548 - 180K
763 x 655 - 163K
756 x 463 - 106K

Comments

  • Zoe
    edited July 10
    Update:

    Just uploaded an image and watched the process of thumbnails generating in media folder.
    I found that the thumbnails were created nearly instantly in the folder, but the browser wait for few minutes before refresh. While the browser was waiting, gm.exe opened and closed several times in Task Manager. 

    Hope this observation will give some hint to the problem.
  • Hi Zoe,

    Have you tried installing the Gmagick extension? We generally recommend that as faster, though getting it to work on Windows can be difficult. 

    As for the permissions issues, you should give your server permission to the entire images directory, as well as flv. I don't believe that will cause performance issues, but it can certainly cause other image upload problems. 

    -Mike 
  • Hi Mike,

    Thank you for your reply. I will try installing Gmagick again. 

    I can only find the latest Gmagick Windows DLL from https://pecl.php.net/package/gmagick/1.1.6RC1/windows . It seems that I must downgrade PHP from 7 to 5.6 in order to match the DLL version, so as to make it working.

    I will let you know if it could fix the problem. Thanks again!

  • Hi Mike,

    I have tried matching different versions of GraphicsMagick with Gmagick and PHP, but still cannot make it working on windows.
    The Apache error log keep saying this error but I did put the dll in the folder:

    PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\\php\\ext\\php_gmagick.dll' - The specified procedure could not be found.\r\n in Unknown on line 0

    My version as below. Does anyone has a successful matching? 

    - 1.1.6RC1, PHP5.6, VC11, x64, TS

    - PHP5.6.31, VC11, x64, TS

    - 1.3.18
    - 1.3.19
    - 1.3.23
    - 1.3.26
Sign In or Register to comment.