Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Pawtucket2 Media Viewer not working (SOLVED??)

edited July 2017 in Troubleshooting
Hi, I am using providence 1.7.3 and pawtucket 2. Only just starting out with pawtucket so not much experience. I can browse to my 1 object in the test database which is a pdf document (I can view this in providence). When I try and open this document in pawtucket I just get the viewer with a spinning block in the thumbnails and main page. My installation is
www/html/providence and www/html/pawtucket

This is my setting in Pawtucket global config - which may be incorrect
# You should not have to change this.
#ca_media_url_root = <ca_url_root>/media/<app_name>
ca_media_url_root = /providence/media/collectiveaccess
# This is to take care of the possible differences between the name of the directory
# path and the URL path due to web server aliases being in play.
ca_media_root_dir = /html/providence/media/collectiveaccess

This is the error message I get in the apache log

[Wed Jul 12 23:52:04.474939 2017] [:error] [pid 27046] [client] PHP Warning:  filesize(): stat failed for document in
/var/www/html/pawtucket/app/lib/ca/Service/IIIFService.php on line 295,
referer:;isOnlyInstance=false&amp;manifestUri=;embedScriptUri=;embedDomain=;domain=;isLightbox=false&amp;locale=en-GB:English (GB)&config=/pawtucket/assets/universalviewer/config.json&c=0&m=0&s=0&cv=0&xdm_e=http%3A%2F%2F127.0.0.1%2Fpawtucket%2Findex.php%2FDetail%2Fobjects%2F58&xdm_c=default4204&xdm_p=4.
any help in solving this will be much appreciated


  • It looks like the IIIF service is not able to write temporary files. Check the permissions for your temporary directory. I do kind of doubt that's really the issue though... I've not seen it before.

    Does the back-end system you're using have custom media processing configuration? Or is it using the default configuration that comes with 1.7.x?

  • Hi Seth,
    The temp file permissions for both providence and pawtucket are the same root:user 0777
    If you are referring to providence/app/conf/media_processing.conf then yes I am using the default configuration.
    Server is Ubuntu 16.02 LAMP with php7
  • edited July 2017
    Hi Seth,
    I have made some progress with this problem. I reset the global.conf to the default and then created a symlink (not sure if I did it correctly) ln -s /var/www/html/providence/media/collectiveaccess /var/www/html/pawtucket/media. I can now get the main page of my pdf document showing in pawtucket but for some reason (probably something Ive got wrong) I cannot see the tile view of the content pages to the left of the main view. I just get triangles with an exlamation mark inside them. I am experiencing the same behaviour in providence. I am using universal viewer. Any suggestions as to where to next?
    P.S I can page through the document in the main screen
  • edited July 2017
    Hi Seth,
    I have been doing my experimenting on a server installed on an old laptop and then transferring my results to my development server. Not having any luck in solving the problem above I decided to try the Pawtucket install directly on the main server and everything works fine. I can see the content tiles and main page in the Pawtucket viewer (set to UniversalViewer). I suspect that I have a resource problem on the laptop . I have tried to find the imagick switch in Pawtucket2 mentioned under media tweaks in the Wiki to see if setting this to 1 helps but cannot find the correct conf file for this. Apologies for the red herring.
Sign In or Register to comment.