Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Stuck on installer page. No place to enter email address

Hi. I am a complete newb and probably in way over my head, but I think I have followed the install instructions pretty well. 

I have providence installed at localhost

I go to localhost/install and this page opens up

The next step in the instructions says to enter an email address, but there is no space for that. There are no error messages, and I do not know enough to troubleshoot this issue as is. 

Currently trying to install on Raspberry Pi 3b

Comments

  • Judging from where the page quit loading there is some issue with the system configuration. I would check your php configuration to make sure that is running properly.

    I am not familiar with Raspberry Pi or its os, but we have had similar "silent" failures where the php memory limit is too low. If that's the case you might want to set it to 128MB. The system should do this by default, but on Raspberry Pi there may be something preventing it.


  • Hi,

    I have the same issue, but trying to install on Ubuntu in VirtualBox.

    Php memory limit is set to 128MB.

    What else can it be?
  • Make sure you have all of the required PHP extensions installed, including the usual suspects like php-xml that are often installed but might not be present by default on a Raspberry Pi.
  • edited August 7
    CRS,

    I managed to install Collective Access on my Raspberry Pi 3b without any real problems. I did, however, at first get the same splash screen that you have. Just to see if there might be a problem with mysql (which I assumed had been installed), I then tried to install WordPress (which was on my list anyway).  Since the WordPress install script gave me a warning that mysql-php5 had not been installed, it dawned on me that that probably was the problem with CA as well. Once I had installed that extension, the installation of both WordPress and CA went through just fine. I had also overlooked a few other php5 extensions that CA requires, but at least for those the CA login script warned me that they had not been installed. Of course, I should have checked for the mysql extension beforehand, but perhaps it would be a good idea to have the CA install script test whether the mysql extension has been installed or not for those of us who are newbies or cannot be bothered to do all the required legwork... BTW, CA definitely runs faster served from my Raspberry Pi than from the shared-hosting site with dreamhost that I administer, although it still is a little sluggish.

    Eisso
Sign In or Register to comment.