Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

SOLVED Search indexing abruptly stopped working

edited January 11 in Troubleshooting
I noticed that the records I've created recently aren't showing up in search results.  Browse is still working fine, so I used browse and the record logs and figured out that we abruptly stopped indexing records on January 4th.  We are using Providence 1.7.5 and we have not made any changes to our configuration recently.  Any suggestions you may have would be greatly appreciated.



  • Try looking for and deleting a file named "search_indexing_queue.lock" in the tmp folder (the app/tmp directory relative to the root of your installation). You're probably using out of process indexing (it's the default), and if a lock file was left in place it would hang up indexing until it's deleted. Once you remove that file indexing should kick in on the next request.  

    You can also force all of the queued indexing to run using the caUtils process-indexing-queue command. The caUtils utility is in support/bin (again, relative to the root of your installation).

  • Thanks!  We removed "search_indexing_queue.lock" this morning and ran the  caUtils process-indexing-queue command.  Unfortunately, search indexing still isn't working.  

  • What happened when you ran the command?
  • There was no output other than:

    CollectiveAccess 1.7.5 (147/GIT) Utilities

    (c) 2013-2017 Whirl-i-Gig

  • It just hung? No return of command prompt? Are you running this on Linux or Windows?
  • No, sorry -- it returned to the command prompt. Running on Linux (Ubuntu16).

  • Try setting disable_out_of_process_search_indexing = 0 in app.conf, then reindex the database and go from there. 
  • diable_out_of_process_search_indexing was already set to `0`;

    Tried one more time, same result.

  • Even after reindexing?
  • specifically running caUtils rebuild-search-index
  • That did the trick! Thanks!

    Do you know if there's something we may have done to cause the "search_indexing_queue.lock" to be left in the /tmp directory?
  • It might have crashed while processing? There's nothing specifically wrong you could have done.
Sign In or Register to comment.