Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

[SOLVED] import data with excel sheet, problem with date in a container

edited January 20 in Troubleshooting
I have to import in providence anagraphic data. I have to fill a container with name, surname, age, date of birth of sons; this container can contain data related to more than one son.
So, in the mapping excel file I write:

Rule type | Source | Ca table.element                | Group | Options

Mapping   |        20  |         | sons     | {"delimiter":";"}
Mapping   |        21  | ca_entities.sons.surname    | sons     | {"delimiter":";"}
Mapping   |        22  | ca_entities.sons.age            | sons     | {"delimiter":";"}
Mapping   |        23  | ca_entities.sons.dateofbirth | sons     | {"delimiter":";"}

In the data excel file I put:

john; michael | smith; smith | 20; 22 | 01/01/98; 01/01/96 |

When I import data, everything is ok, except dates.
Providence creates fields for name, surname, age and dateofbirth for every son and fills the fields with the correct value except the date field. If in the import procedure I put only one date in the excel date cell, this date is assigned to the first son, if I put two dates in the excel date cell, I have error.
I try to change the cell format of the date on the excel file but the problem remains...
Any suggestion?


  • I partially solved the problem.
    In the excel file I modified the cell format of dates, from date to text, so providence see date as text and fill records in the correct way.
    The problem now is that these dates are in text format, but this was what I needed.
Sign In or Register to comment.