Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

How to transform georeference data in the importation map?

edited February 14 in Troubleshooting
Hello again... I´m a little bit awkward and I have another problem....
Well, I would like to import files with different georeference formats (the ones used by the ordinary photo camera por example), to the format is used by Collective Access. I guess I have to do that in the importation map, but I don´t know in whick fields or how to do that...
We are using the default mapping, please, could someone tell me how to do that?
We are using Providence 1.7.5
Thank you very much.
Best regards


  • edited February 14
    Hello, nobody can tell us something?
    Well, I´ll tell you the steps we have follow until now.. maybe it could be easier with a concrete example.
    We are using the import "mapping" to collect GPSPosition data generated by digital cameras, or geolocated with Adobe Lightroom.
    We have done several tests with IMG_4184.JPG picture. Applying "exiftool" we see the following metadata:

    <?xml version='1.0' encoding='UTF-8'?>

    <rdf:RDF xmlns:rdf=''>;


    <rdf:Description rdf:about='IMG_4184.JPG'

      xmlns:et='' et:toolkit='Image::ExifTool 10.40'















    <Composite:GPSAltitude>638.4 m Above Sea Level</Composite:GPSAltitude>

     <Composite:GPSDateTime>2018:01:28 10:05:15.07Z</Composite:GPSDateTime>

     <Composite:GPSLatitude>42 deg 26&#39; 29.42&quot; N</Composite:GPSLatitude>

     <Composite:GPSLongitude>2 deg 57&#39; 11.56&quot; W</Composite:GPSLongitude>

     <Composite:GPSPosition>42 deg 26&#39; 29.42&quot; N, 2 deg 57&#39; 11.56&quot; W</Composite:GPSPosition>






    The "mapping" rule we have used is:

    Mapping --- Composite/GPSPosition ----  ca_objects.georeference

    NOTE: we haven´t put anything in "Refinery", “Refinery parameters”, “Original values” and “Replacement values”

    Result: unsatisfactory

    The "Georeference" doesn´t match at all with the GPS position...

    We understand that CA use KML/KMZ forma, which is decimal, and doesn´t convert correctly the usual GPS values of digital cameras and Adobe Lightroom.

  • image
    Reading the embeded metadata in "MEDIA, we see the following results:


    CHANGE in the original distribution
    Reviwing the CA configuration, we saw that it is possible to use as an alternative "exiftool" application.
    In /app/conf/app.conf we changed "dont_use_exif_read_data" to 1, in order to extract the metadata with "exiftool".

    The result in "COVERAGE" is the same, but metadata haven´t been imported correctly to the object´s record as "georeference". But now, the read values of embeded metadata in MEDIA are correct.

    - Could be solved this problem with "Refinery", "Refinery parameters", "Original values", or "Replacement values"?
    We think that it is very important CA could be compatible with metadata formats used by digital cameras and Adobe Lightroom.
    If this problem isn´t solved, maybe could be helpful this reference:

    Thank you very much and best regards.
    885 x 437 - 51K
    885 x 525 - 63K
    885 x 331 - 62K
    883 x 452 - 60K
Sign In or Register to comment.