Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Table not found error

edited 4:38AM in Installation
I've recently set up CA in our test environment, and we're working through finding our way around the system. I came across the following error when I tried to delete from Lists and Vocabularies:

SELECT ca_storage_locations.type_id item_type_id, ca_storage_locations.location_id, ca_storage_locations_x_vocabulary_terms.sdatetime, ca_storage_locations_x_vocabulary_terms.edatetime, ca_storage_locations_x_vocabulary_terms.type_id relationship_type_id, ca_storage_locations_x_vocabulary_terms.relation_id, ca_storage_location_labels.name, ca_storage_location_labels.locale_id, ca_storage_locations_x_vocabulary_terms.source_info, ca_list_items.item_id AS row_id FROM ca_list_items INNER JOIN ca_storage_locations_x_vocabulary_terms ON ca_list_items.item_id = ca_storage_locations_x_vocabulary_terms.item_id INNER JOIN ca_storage_locations ON ca_storage_locations_x_vocabulary_terms.location_id = ca_storage_locations.location_id INNER JOIN ca_storage_location_labels ON ca_storage_locations.location_id = ca_storage_location_labels.location_id WHERE (ca_storage_location_labels.is_preferred = 1) AND (ca_storage_locations.deleted = 0) AND (ca_list_items.item_id IN (193)) ORDER BY ca_storage_locations_x_vocabulary_terms.rank Table 'nysa_collective.ca_storage_locations_x_vocabulary_terms' doesn't exist

I looked in the database, and I don't see this table... is there somewhere I can get the SQL to create this table?

thanks,
-Tim

Comments

  • That's really strange. It should be there, and is in our trunk copy. Try loading this file in your database. It creates the missing table.

    seth
  • That worked perfectly... thank you :-)
    I'm working through a few more issues, so you may see another post... but progress so far feels good.
  • Great. That shouldn't be happening so I still have some work to do. It's definitely not a problem in 1.2 (the current development code)
  • Interestingly, I'm having another table-related error... After a recent download of the latest Pawtucket, it is now looking for a ca_bundle_mappings table. None exists in the database. I've also downloaded the new Providence to see if it needed to update the database, but it did not.

    The related error is this:

    Error 282: Table does not exist
    Table 'nysa_collectivetest.ca_bundle_mappings' doesn't exist

    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/core/Db/mysql.php:caPrintStacktrace@293
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/core/Db/DbStatement.php:Db_mysql:execute@130
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/core/Db.php:DbStatement:executeWithParamsAsArray@271
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/models/ca_bundle_mappings.php:Db:query@595
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/ca/BaseFindController.php:ca_bundle_mappings:getAvailableMappings@195
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/ca/BaseBrowseController.php:BaseFindController:Index@92
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/controllers/SplashController.php:BaseBrowseController:Index@96
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/core/Controller/RequestDispatcher.php:SplashController:Index@215
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/app/lib/core/Controller/AppController.php:RequestDispatcher:dispatch@112
    /mars/www/https-Apps/appsdocs/archives/ca/pawtucket/index.php:AppController:dispatch@113

    (in Db->mysql->execute())
    Request halted.
  • There's a stray reference in Pawtucket/master to a table we're phasing out. It'll be cleaned up shortly. Sorry.
  • edited August 2013
    I'm having the same issue as ttilstra, related to the "Error 282: Table does not exist" problem. Is there a way to fix this manually?
  • Which table?
  • here is the Pawtucket error I'm getting:
    Error 282: Table does not exist
    Table 'zinecore2.ca_bundle_mappings' doesn't exist

    /var/www/14/app/lib/core/Db/mysql.php:caPrintStacktrace@293
    /var/www/14/app/lib/core/Db/DbStatement.php:Db_mysql:execute@130
    /var/www/14/app/lib/core/Db.php:DbStatement:executeWithParamsAsArray@271
    /var/www/14/app/models/ca_bundle_mappings.php:Db:query@595
    /var/www/14/app/lib/ca/BaseFindController.php:ca_bundle_mappings:getAvailableMappings@195
    /var/www/14/app/lib/ca/BaseBrowseController.php:BaseFindController:Index@92
    /var/www/14/app/controllers/SplashController.php:BaseBrowseController:Index@96
    /var/www/14/app/lib/core/Controller/RequestDispatcher.php:SplashController:Index@215
    /var/www/14/app/lib/core/Controller/AppController.php:RequestDispatcher:dispatch@112
    /var/www/14/index.php:AppController:dispatch@113

    (in Db->mysql->execute())
    Request halted.
  • You'll need to update Pawtucket to the latest code.
Sign In or Register to comment.