Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Pawtucket and locales

edited 11:50AM in Pawtucket
I am trying to enable Polish locales but I'm still missing something.
1. I have copied pawtucket/app/locale/en_US/messages.* to pawtucket/app/locale/pl_PL/messages.* and translated that file in poedit.
2. I have included

locale_defaults=pl_PL

in pawtucket/conf/global.conf and made sure Polish locale exists in ca_locales table.

pl_PL locales work fine in Providence but not in Pawtucket. I still see only English, Deutsch and Francais in the language selector.

Comments

  • Try adding pl_PL to the "ui_locales" list in pawtucket/app/conf/app.conf or, if your theme has a theme-specific app.conf file, in themes/<your_theme>/conf/app.conf (this overrides the global app.conf file)

    like so: ui_locales = [en_US, pl_PL]
  • Right, now I got Polish in the pull-down menu on the pawtucket main page, sometimes it works and I can see some of the messages in Polish, sometimes I'm getting "Could not load language 'pl_PL'" but that's probably because my translation is still far from complete. I'll send the translation when it's sort of usable.
  • Still no luck, I got localization of Pawtucket's messages.po 100% finished but the only pages which display properly with Polish localization are

    http://localhost/pawtucket/index.php/LoginReg/form
    http://localhost/pawtucket/index.php/simpleGallery/Show/Index
    http://localhost/pawtucket/index.php/About/Index

    All other pages display only

    Could not load language 'pl_PL'

    Would be very grateful for any ideas.
  • It seems it's not an issue with cleanup_before_release version.
  • Ok, can you use that version or is it a problem?
  • I know this is an old thread, but did you solve this? I got the same problem. Info pages works fine but detail pages and some browse pop ups give me "Could not load language".
  • For what locale? sv_SV?
  • Yep. Tried with an old translation and with a newly created one based on the files from the github. As soon as I name something sv_SE it fails. Even if I copy the exact files from the german och french translations.
  • What do the locale settings in app/conf/global.conf look like?
  • Right now its [en_US, de_DE, sv_SE] but I've tried with just sv_SE as well. I also tried different variations for the UI locales in app.conf and default locale in setup.php
  • Any news regarding this?
  • Did you create a translation for the date parser in app/lib/core/Parsers/TimeExpressionParser/ ?
  • I did not. But now I have and it works! Thanks. I love when there's an easy fix.
  • Sorry I did not think of that earlier. For what it's worth, the steps required are mentioned here: http://docs.collectiveaccess.org/wiki/Translations
  • edited May 2016
    I'm having also trouble with the translation file in pawtucket.

    I generated a folder de_CH in app/locale and generated the .po file a new with poedit.
    I updated the following files/configs:
    setup.php:      define("__CA_DEFAULT_LOCALE__", "de_CH");
    app.conf:        ui_locales = [de_CH]
    global.conf:    locale_defaults = [de_CH]
    Finally I created a translation for the date parser and added an entry to the ca_locales table.

    Non of the translations I made so far are showing on my website. It is simply printing the text within _t("   ").
    ----------
    Correction: some of the terms show translated on the site.

  • Is this pawtucket or pawtucket2?
  • It's pawtucket2
  • Ok, now more and more terms are being translated one by one. It seems everytime I refresh the page another one appears translated somewhere.
    Really odd behavior.
    There is no difference in which browser I'm using, so I can rule out something browser history/cache related.
  • Try killing the translation cache in app/tmp
  • Thx! Deleting all content of the tmp folder did do the trick.
  • Unfortunately, still not all terms are translated. Some that already were translated reverted back to english and other single ones never change.
Sign In or Register to comment.