Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Changing length of intrinsic field via UI editor

In our Providence installation, I would like to make it possible to give objects id numbers longer than 30 characters. I just updated our code from Git (application 1.3, schema 72), and am unable to increase the length of this field through manage-->admin.-->UI-->object editor. When I save the new field length value (100), it appears to save in the UI editor but does not actually change the length of the field in the object cataloging screen.

I had this problem in a previous version and was able to change this setting once I installed the newest schema revision, but I don't think this solution will work this time since I just reinstalled using the newest revision.

Please help. We use filenames as identifiers for digital objects, and our naming conventions mean that many of our filenames are longer than 30 characters.

Thanks in advance!
Elizabeth

Comments

  • You can change the width of the identifier field for objects, and other record types as well, in the multipart_id_numbering.conf file in app/conf. This is the file the controls all aspects of identifier entry, validation and automatic generation.
Sign In or Register to comment.