Related object

edited November -1 in General Support
Hi,
I have a problem with "related object" metadata.

I have a lot of objects. When I type in the box of "Related object" the object ID of the object that I want to relate (e.g. ComVM.2 - first screenshot) CA don't show me this object that I'm sure exists (second screenshot). Due to this I can't relate my object.
This problem came to light when the number of objects has become relevant, before of this the metadata "related object" worked properly.
There is any setting that I need to configurate (e.g the maximun number of record displayed in the dropdown list of "Related object" metadata)?
Thanks,
bye
PM

[attachment=134010,618]
[attachment=134010,617]

Comments

  • Hi,

    It might be that that search is coming up with too many matches and the one you want happens to be at the bottom and omitted. The maximum # of returns is 100 in this version of CA.

    Try searching for the number in double quotes and see if that makes a difference. That should force an exact match to be made. If this doesn't help, there are other adjustments that can be made in search.conf:

    1. Set search_sql_search_do_stemming to 0 instead of 1. This will disable stemming and make the number match exactly.

    2. Add a regular expression to asis_regexes that conforms to the id numbering scheme. "asis_regexes" is a list of pattern matches (regular expressions); search input that conforms to any pattern in the list is used verbatim in the search. Other input is broken apart on punctuation which can lead to wonky results when the search is an identifier.
  • Hi Jon, thanks for your reply.

    I tried to search the number in double quotes but it doesn't work.

    I set search_sql_search_do_stemming to 0 instead of 1 and also this doesn't work.

    About your last advice I ask you where I have to add regular expression. I looked for asis_regexes but I can't find it.
    Thanks a lot!

    Bye
    PM
  • Should we increase the number of matches? 100 is an admittedly arbitrary limit.
  • Hi,

    Having a similar issue when trying to relate entities from an object record. Some searches bring up a really long list of entities, but the actual search term won't be on it. Seems like the list is of other entities that are related to the person I'm trying to add?

    Searching in quotes don't seem to affect the results. Could you explain where to make that "search_sql_search_do_stemming" change?

    Also, is there a way to sort the autofill search results alphabetically by name? Tried using the standard object editor to do this on the editor element level, but wasn't offered "display name" as an option to sort by.

    Thanks!
  • The search used for lookup, by default, casts a wide net. It's basically a full-text search, so if the words you're looking for are general you can get a lot of garbage. To address this use any of the following:

    1. Use more specific search terms
    2. Qualify your searches to look only in specific fields (the same syntax outlined in http://docs.collectiveaccess.org/wiki/Search_Syntax works for lookups too)
    3. Change the indexing to not index fields with lots of general text

    #3 is most effective but may limit the effectiveness of other searches in your system.

    We should probably add a way to configure scope limits on lookup searches. Treating lookups as regular searches usually works well, but when it doesn't it's frustrating.

    Regarding sorting, technically it's possible although we don't expose this as a configuration option at the moment. Maybe we should. The default sort is by relevance, which is usually what you want: the closest matches first. When none of your search results is particularly relevant, this can seem kind of random though.


    seth
  • We have the same problem mentioned at the beginning of this thread, CA does not display the list of available objects in a field of the type "Related objects". At the moment we have loaded very few records. Every time new records are entered it is necessary to update the search indexes.

    On the other hand, this is an encoded field that contains hyphens (-) and does not look for an expression with two characters plus a hyphen such as "xx-", except if we use the wildcard *, like this: "xx- *".

    What would be the problem? How can we solve it?

    Thank you very much in advance.

Sign In or Register to comment.