Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Problem adding image media files

yabyab
edited 7:33AM in Troubleshooting
Hi!

I cant add any image files to CA objects.

The error is:
"There are errors preventing information in specific fields from being saved as noted below.
Unknown file type not accepted by media"

I've attached a screen shoot with my media processing plugins:

[attachment=31797,544]

/Mattias

Comments

  • What sort of formats are you trying to add? And is your ImageMagick built to accept those formats?
  • Its jpg, gif, png and bmp.
    How can i see what ImageMagick is built to accept?
    Its on a shared hosting enviroment so i haven't installed
    it myself.
  • Try typing identify -list format on your server's command line.

    Even if your Imagemagick can handle BMP, CA is not configured for it. The others should definitely work if ImageMagick is configured to support them.
  • ImageMagick is configured to support most image
    formats including jpg, gif and png.

    What else can cause this problem?
  • Are you running this on Windows, Mac or Linux?
  • Its on a Linux server.
  • Try setting dont_use_imagick in app.conf to 1 and try it again. Does it make a difference?
  • I get the same error.
    When checking the configuration under Imagick plugin it says: "Didn't load because Imagick is not available"
    The "GD" plugin says: "Available".
  • If GD is available and can't handle a PNG or JPEG then it's probably not CA or the graphics processing back-ends. It's probably at a lower level.

    Are you running SELinux? We've seen that cause these sorts of issues.

    seth
  • No we're not running SELinux.
  • Hi,

    Sorry for the delayed response. I'm running out of ideas so bear with me please. Can you send me the output of phpinfo()? Specifically I'm interested to see if your GD library is built with JPEG support. Not all are.

    If it is, then I'm kind of out of ideas. Is there any chance I can take a look at the server itself?
  • Hi,
    I have the same problem as Yab. GD is said available but I have the error message: "Unknown file type not accepted by media". I tried with PNG and JPG images. I've installed CA 1.3 on a shared server. You can look at the phpinfo() here: http://laure.olympe.in/phpinfo.php. I you have any idea?
    Thank you,
    Laure
  • It's available, but is it being used? Are there any other media processing plugins being detected?
  • As you said, I have disabled ImageMagick in app.conf. You can see the plugin available in the attached screenshot.
  • How big are these files you're trying to upload?
  • Very small, less than 100 ko for the moment
  • Try uploading them to demo.collectiveaccess.org. Do they upload ok there?
  • Yes on demo.collectiveaccess.org I can upload them.
  • Ok, then my guess is that GD is your shared host is broken in some strange way.
Sign In or Register to comment.