Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Photos and texts in Pawtucket

bbbbbb
edited July 2013 in Pawtucket
Hello,
I'm trying to create a few records with Collective Access Quickstart version, and I have problems with Pawtucket.
I made my objects in Providence, with title, object identifier, administrative/biographical history element, dates, type, related object and some photos visible in the summary. But Pawtucket shows me only the title and, instead of the photos, a white rectangle.
I would like that all the information I put in Providence would be shown in Pawtucket, in particular the photos!
Thanks!

Comments

  • In order to display your Providence metadata in Pawtucket, you'll need to configure the page. To do so, copy "# --- attributes to display on detail pages" from app/conf/app.conf into /themes/your_theme/conf/app.conf. Make sure to use the elementCodes for the attributes. For the photo, make sure that the access status on the media in Providence is set to "accessible to public."
  • Sorry I can't find /themes/your_theme/conf/app.conf. I have to search it in Providence or Pawtucket?
    And the photos are all set to "accessible to public" in media in Providence.
    Thank you in advance!!
  • There is no theme called "your_theme"---that is my placeholder for whatever theme you have chosen. You need to use a preexisting theme or you must create a new one in order to configure Pawtucket. The theme is set in setup.php and out-of-the-box the software uses "default".

    Try setting "dont_enforce_access_settings = 0" in app.conf and see if the photos show up.
  • I m having the same issue with my install of Pawtucket. I have white boxes with a black x on them. I have tried all the solutions that you mentioned here but none worked.
  • To clarify, dont_enforce_access_settings should be set to 1. Is that what you tried, jrivera?
  • Yes I did but the theme still doesn't show.
  • Your images are broken. Take a look at the URLs the system is generating. You have an incorrect setting somewhere, or you didn't bother to symlink the media folder properly. Good luck.
  • My images show fine. The symlink is done properly. The problem I am having is with the theme. The theme is not showing correctly. Why would the theme not show? Please advise.
  • It looks like it is pointing to the wrong path to access the theme. It is pointing to /Pawtucket/var/www/html/themes when I think it should be pointing to /var/www/html/Pawtucket/themes. I looked for this setting to fix but I can find the setting. Please advise.
  • Your configuration is wrong most likely. Look it over carefully.
  • Lol thanks for the insight....
  • Forgive me, but you always have to configure the page to show what you put in providence in pawtucket, or it is a problem?
    Because for who is not a computer programmer it is really difficult!
  • Hi bbb. Yes, it always must be configured and that's because CollectiveAccess allows you to create custom fields. With unique fields in every installation, there can be no default display for all users. The simple comma separated list of codes in app.conf is designed to allow users to add fields to the screen without programming.

    In future releases of Pawtucket we hope to provide more graphical tools for configuration.
Sign In or Register to comment.