Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Hierarchical collections

I started evaluating collective access for a collection of around 20,000 photographs. All the photographs are organized in collections that are nested (e.g. Monastery->Church->Frescoes->Nave). So far I installed both back and front-end of the collective access, reviewed docs, forums, and created couple of collections, but was not able to find the following:

(1) Is there a step-to-step description how to turn ON hierarchical collections? From what I see on the forum it is possible, but the technicalities are not that clear.

(2) Has anyone tried to import images from the Lightroom with preserved Lightroom collection tree, image metadata, etc.

Thanks,
Nenad

Comments

  • Hi Nenad. I've just added a CollectiveAccess "Cookbook" topic for your question 1 above. Let us know if you have any additional questions.

    http://docs.collectiveaccess.org/wiki/CollectiveAccess_Cookbook#Using_hierarchical_records
  • edited July 2013
    Thank you. That worked, even though, I was not able to create nested collections with UI interface, (a) New->Collection->collection on UI did not have any follow up name in the hierarchy, (b) Created collections started disappearing as soon as I created new ones. Once I changed install profile everything worked.

    I am looking into the front end interface and somehow my collections are not showing up. Is there a way to show collections in their nesting form?
    Like:


    collection2
    collection3
    collection4
    collection2

  • (a) did you click "Add under List item types (list_item_types) new [concept] +"? under collection_types in Lists and Vocabularies?
    (b) how did you try to search for the created collections?

    Make sure your collection records are set to "accessible to public" if you want them to show up on the front-end. Where do you want the collections to appear in their nested form?
  • Yes, that is how I added them. After entering the second collection on the same level the first one disappeared from that level. I was looking at the hierarchical browser. Anyway, I am happy that the other way works well.

    > Where do you want the collections to appear in their nested form?

    When I brows for collections in Pawtucket. All my collections are accessible to public but I don't see anything under browse->collections.
Sign In or Register to comment.