Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

ffmpeg errors

edited August 2013 in Troubleshooting
I have a new installation I am testing. I can't seem to upload any video. When I try to either upload or import, I get "Couldn't convert file to MPEG4 format [1]". I have successfully uploaded an audio file. I had to use ffmpeg to convert it from m4a to mp3. I cannot get video to work. I tried the same conversion trick but CollectiveAccess still won't take it. I am using ffmpeg on the server to do the conversion to mp4 so obviously ffmpeg works. I've done the audio so CA is connected to ffmpeg. The file is only 20 MB.

I can't find any error log of any kind on the server. Apache error_log reports nothing. PHP display_errors is On. My configuration check says that everything is good. I imported a couple of PDF file with no problem.

I tried earlier with a Dreamhost shared hosting account. CA works there but I can't process any media at all. Nothing but 500 server errors. I am now using a bare-bones VPS from canadianwebhosting.com. Supposedly a VPS is supposed to work. I'm at a loss.

Comments

  • It turns out I was missing libfaac. I haven't setup a Linux system in 10 years. I was surprised at how little processes has been made. I still have to hack up source code to make it build.
  • Most stuff is packaged now, but ffmpeg for patent and other reasons, generally is not. It's definitely a bit of a nightmare to set up.
Sign In or Register to comment.