Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

caSendMail Fail

edited August 2014 in Troubleshooting
I had written a simple plugin that displays a contact form in Pawtucket and since upgrading to v.1.4 it has quit working. See the form at http://digitalcollection.waynehistoricalohio.org/index.php/formContact/formcontact/Index

I have traced the failure to the function caSendMail in the mailHelpers. My webserver company says nothing has changed on the server and to check with the CA developers. I did not change any of the smtp settings in the setup.php file and the below settings worked before the upgrade:

# __CA_SMTP_SERVER__ = server to use for outgoing mail
#
define("__CA_SMTP_SERVER__", 'localhost');

# __CA_SMTP_PORT__ = port to use for outgoing mail
#
define("__CA_SMTP_PORT__", 25);

Have any coding practices for plugins changed between 1.3 to 1.4 that may have twerked my plugin? Or is it a setting that needs to fixed?

Comments

  • That's strange. Look in the global.conf file. What do the smtp_* entries look like?
  • I have not changed them from default settings because previously everything worked set like below in Global.conf:
    # -------------------
    # Email
    # -------------------

    # SMTP server to use for outgoing email notifications
    # If your server isn't running a mail server locally, the default smtp_server value will have to be changed
    # __CA_SMTP_SERVER__ = server to use for outgoing mail
    smtp_server = __CA_SMTP_SERVER__

    #
    # If your SMTP server requires you to authenticate then you can set the login information
    # below by uncommenting the smtp_auth, smtp_username and smtp_password lines and giving them appropriate values
    #
    #smtp_auth = __CA_SMTP_AUTH__
    #smtp_username = __CA_SMTP_USER__
    #smtp_password = __CA_SMTP_PASSWORD__

    # Generic site admin email
    ca_admin_email = __CA_ADMIN_EMAIL__

    # From: address for password reset emails
    password_email_from = <ca_admin_email>

  • This is the relevant section of global.conf that I had to add to get senmail to work through my shared server (Pair hosting).  If you look to the config parameters used in mailHelpers, some of them are not defined in the standard configuration files and must be added by hand.

    # -------------------
    # Email
    # -------------------
    # SMTP server to use for outgoing email notifications
    # If your server isn't running a mail server locally, the default smtp_server value will have to be changed
    smtp_server = __CA_SMTP_SERVER__
    smtp_port = 465
    smtp_ssl = ssl
    smtp_use_sendmail_transport=0
    #
    # If your SMTP server requires you to authenticate then you can set the login information
    # below by uncommenting the smtp_auth, smtp_username and smtp_password lines and giving them appropriate values
    #
    smtp_auth = __CA_SMTP_AUTH__
    smtp_username = __CA_SMTP_USER__
    smtp_password = __CA_SMTP_PASSWORD__

    # Generic site admin email
    ca_admin_email = __CA_ADMIN_EMAIL__

    # From: address for password reset emails
    password_email_from = <ca_admin_email>


  • Gord, i tried your suggestion but it did not work for my shared-server; but i think you're solution is probably the closest to solving the problem but my server company won't tell me what the port settings should be and if ssl or authentication is required for outgoing mail and keep telling me to ask the developers but how are the developers supposed to know what the settings are on the server? One of those catch-22 situations.

    But thanks for the suggestion; i'll keep playing with the settings and see if i can find one that works.
  • edited August 2014
    You can also try port 587 and tls encryption or (less common) port 587 and ssl encryption or (rarely) port 25 and ssl encryption.
    It is also important to get the SMTP sever name correct.  In my case it is the address of my web mail server (gordb.mail.pairserver.com)
    My username is my webmail user id (gordb@apraarchives.net) and my password is my shared service account login password.
    The authentication method is "login"
    I also set the CA_ADMIN_EMAIL to be a defined webmail mailbox (archivemaster@apraarchives.net) but in my case it doesn't really matter. Some ISP's are touchy about it.

    It sounds like whom every you are talking to on your server company really doesn't know what they are talking about.  SMTP is configurable to the server and not defined by the developers of the outgoing e-mail software.  You need to dig in more to find someone with a brain.

    You can always switch to pair systems.  They publish all this stuff in their FAQ library.  I didn't even have to ask anyone.
    When you do get it running watch out for your theme/conf/contact.conf file.  I accidentally several test e-mails to the default e-mail address configured there.  I always forget to check the theme configuration overrides.

    Best of luck in your experimentation

  • I had to install sendmail with yum on our CentOS Server. Look into your apache error_log. It said sh: /usr/sbin/sendmail: No such file or directory

Sign In or Register to comment.