Support chat room

edited January 2019 in General Support
If you have quick questions that are perhaps better handled in chat feel free to stop by the new support channel at https://gitter.im/collectiveaccess/support
We'll try to keep it staffed as often as possible! 

Please feel free to keep posting your issues here as well, especially larger and general interest topics that others may benefit from reading.

Comments

  • Install CollectiveAccess on local NAS
    I would like to install CollectiveAccess on QNAP TS-439 Pro II NAS box.
    Has anyone had experience with this or can direct me to an appropriate information source?
    Thanks, Murphy Shewchuk
    Nicola Valley Museum & Archives
  • You may want to open a separate thread for this. We'll be happy to answer any questions there!
  • Hi Stefan,

    I am quite new to Collective Access(CA) .

    I have question with regard to portability of CA.

    Is CA compatible on hand held devices such as Ipads, Iphones and tablets..

    If yes, appreciate if you could guide me to documentation on installing CA on Ipad.

    Thanks,

    Daniel Moses


  • Hi Daniel,

    Please post this as a separate thread. Thanks.


    seth
  • Hello,

    I'm sure you get this question a lot. I have installed Pawtucket from latest branch (https://github.com/collectiveaccess/pawtucket2/tree/develop) but I still can't have the media symlink read the ca/media files. I have tried everything possible but still no luck. I tried setting the Item viewablity (access enforcement) to 1 but still no use. What Am I doing wrong to get the images to show up on Pawtucket? 

    Thank you for your time. 
  • Hi Jamal, please start a separate thread for this issue, or post it in the chat room: https://gitter.im/collectiveaccess/support
  • In which line the necessary changes have been made in 'setup.php' file of providence?

    CA_DB_HOST = Database server host name (often 'localhost')

    #
    if (!defined("CA_DB_HOST")) {
    define("CA_DB_HOST", 'localhost');

  • Hello,

    I have forked the Providence repo and installed CA 1.7.8 with Installation Profile set to [Testing] Profile for test cases. Then I logged in with the administrator user provided after the installation finished and set User Inteface locale to português (Portugal) in menu Manage > My Preferences.
    I edited some dashboard message strings in Providence > app > locale > pt_PT > messages.po and generated the corresponding messages.po file using command:_ msgfmt messages.po -o messages.mo_.
    However, when reloading the dashboard page, the edited message strings are not updated (the default pt_EN text is still displayed). Could You please advise on the procedure for testing translations on a local installation?

    Thanks!

  • starting from https://docs.collectiveaccess.org/wiki/Getting_Started I am trying to follow the link toward the bottom to the schema library but keep getting a Page Not Found error. is this page down or is the link address wrong?

  • Can I ask what appears to be an obvious question to me. Why isn't there a Live boot image of a working CollectiveAccess configuration or a virtual machine image (VirtualBox) for people to try out rather than making them piece everything together? Is it differences in OpenSource licensing? Having some Linux experience it wasn't too bad but I know many people to whom it would be an overwhelming task. A Live boot image would allow people to try it out in a couple of steps rather than dozens. I think it is worth the effort because it seems a good and stable package but then again I am more stubborn than most ;-).

  • Too many things to do, not enough time. If someone wants to maintain one we'd be grateful.

  • Thanks Seth. I appreciate a straightforward answer. I am chronically ill otherwise I would think about taking this on. As it is just getting one installation is enough for me. If you can connect me with a CA user who maintains a small, private, one-artist collection I would appreciate it.

  • Hello,
    we have installed Collective Access version 1.7 and we have noticed that each "class" (ex: Object, Object Lots ...) have default variables (metadata elements).

    Is there a list of these default variables?

    Is there a way to associate a user account to a "class" (ex: Object, Object Lots ...)?

    Thank you

    Stephen Petterson

  • Hi Stephen,

    It might be better to move this to a separate topic, but I'll provide a quick answer here:

    Is there a list of these default variables?

    There's a set list of primary record types (aka. tables) on the documentation wiki (https://docs.collectiveaccess.org/wiki/Primary_Types). You may find the page in the in-progress manual (http://manual.collectiveaccess.org/dataModelling/primaryTables.html) easier to to read. Please keep in mind that the new manual site is very much a work in progress.

    Is there a way to associate a user account to a "class" (ex: Object, Object Lots ...)?

    It is possible to create roles for users that restrict their access to specific record types, or sub-types of those records.

  • Hello, is there anyone in here who can install CA for payment? I tried and failed. Thank you so much, Will.

  • Dear all, We are planning to implement your software as repository solution for our physical holdings. ​We plan to host the software on our own servers but we would like to inquire on the cost of per hour consultations regarding maintenance, updates/ upgrades ​as well as other support that might be needed for any issues that might occur with the software.

    Is anyone aware of any consultation companies in Poland preferably or other EU countries?

    Thank you

  • Hello - just wondering if anyone else has had trouble with the installer and file permissions. System installed ok up to the installation from the web browser but now gives me this message "The CollectiveAccess app/tmp directory is NOT writeable by the installer. This may result in installation errors. It is recommended that you change permissions on this directory (/var/www/html/ca/app/tmp) to allow write access prior to installation. You can reload the installer to verify that the changed permissions are correct."

    There are four similar messages for the directories you have to set to 755. I have now changed them all to 777 and I still get the messages which can't be true but you can't get any further with the install.

    Thanks

    Ray

  • That message indicates that CA can't write to those directories. Straight permissions aren't the only thing that can cause them to be unwrite-able. Are you running Linux? If so, do you have AppArmour or SELinux running?

  • Spot on Seth. Thanks for that. Forgot all about SELinux - have set to permissive for now as this installation is just for evaluation purposes. Running Centos 8 on VMWorkstation but been a while since I did any IT work :)

    Regards,

    Ray

  • Hallo. Just installed v 1.7.11, and cannot access "Access Control" menu, with an ERROR 500 returned.

    Everything else is working fine.

    Any hint?

    Thank you

    G

  • Solved. It was a PHP parameter: max_execution_time too low.

  • Anyone else had trouble with the SPECTRUM compliant version. Got most of the others to work fine but this one jumps out 3 quarters through the installation every time and unfortunately this is the version I need. Any way to just download the database creation script?

  • There is no script. You need to use the installer. I'd check the PHP memory limit parameter on your server. Perhaps it's too low. If it's set to 128M consider bumping it to 256M.

  • Solved Spectrum download. Tried PHP memory limit - upped to 512M but didn't work. Created new file my.conf in /etc/httpd/conf.d/ and added lines:

    Timeout 2400

    ProxyTimeout 2400

Sign In or Register to comment.