Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

List attribute as a facet for browsing

Hello,

I'm trying to use a list attribute as a facet in the browse.conf, but it's not rendering in the browse view in pawtucket. How does facets works with list attributes? I noticed that there's Status and Access attribute are used as a facet in the browse.conf and, a system list they both.

Thanks!


Comments

  • Can you post the snippet you're using for that attribute? It should work, but you have to set the browse "type" to "attribute" and then set the "element_code" to the code of your list attribute. Using the "fieldList" from the access/status facets won't work -- that's for intrinsic/hardcoded fields
  • edited March 2016
    Hi stefan, 

    Sorry, I figured out what happened (I guess). The itens in the list used by the metadata element was not accessible to the public. At first I thought it could be some cache problem, but once I turned the itens to "public access", the facet started to work. Does it make sense?

    Anyway, the facet was setted like you said:

    category_facet = {
    type = attribute,
    element_code = entity_category,
    group_mode = alphabetical,
    label_singular = _("entity category"),
    label_plural = _("entities categories")
    }

    Thanks!

  • Hallo! I am trying to create an attribute facet for storage locations, but I cannot get it shown on Providence.
    The code I am using is as follows (under ca_storage_locations):

    locazione_status_facet = {
    type = attribute,
    field = storage_location_status,

            group_mode = none,
    
            label_singular = "Stato_Collocazione",
            label_plural = "Stati_Collocazione"
        }
    

    The attribute "storage_location_status" is a list. Is there anything to set on the referenced list?
    Thank you,
    G

  • Try replacing "field" with "element_code".

  • Fine, thanks!

Sign In or Register to comment.