Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

media panel php/header errors

edited June 2016 in Pawtucket
Hi! I'm using Providence 1.6.1 and the Pawtucket develop branch. When I open the media viewer on the detail page of an item in Pawtucket, I get this output at the top of the page:


Deprecated: Automatically populating $HTTP_RAW_POST_DATA is
deprecated and will be removed in a future version. To avoid this
warning set 'always_populate_raw_post_data' to '-1' in php.ini and use
the php://input stream instead. in Unknown on line 0



Warning: Cannot modify header information - headers already sent in Unknown on line 0



Warning: Cannot modify header information - headers already sent in /Users/melas/Sites/pawprint/app/lib/core/Controller/Response/ResponseHTTP.php on line 163



Warning: Cannot modify header information - headers already sent in /Users/melas/Sites/pawprint/app/lib/core/Controller/Response/ResponseHTTP.php on line 163

I've tried a few things to fix the error or even stop it from displaying. I have made the change to php.ini. I have turned off display errors. I have tried removing the debug bar from pageHeader.php and pageFooter.php. I have tried other branches of Pawtucket. Any thoughts?

Comments

  • Looks like your PHP is showing deprecated warnings. Are you using a very old setup.php template by any chance? Try copying the latest setup.php-dist and changing all the relevant values again

    Quick side note: We don't really support the old Pawtucket anymore (unless we have to). If you're just starting out you should be using pawtucket2: https://github.com/collectiveaccess/pawtucket2
  • Hi Stefan, thanks for replying.

    Today I did a fresh install of pawtucket2 from the develop branch. I filled out a new setup.php and left everything else out of the box. Then I checked phpinfo() for any clues. I'm using 5.6.17, if it matters. I did find out I was editing the wrong php.ini file for apache. I found the right one, made the 'always_populate_raw_post_data = -1' change there, and looked for any other .ini files that might be conflicting. Restarted the server a bunch of times, no change. For whatever reason, phpinfo() is still insisting that always_populate_raw_post_data = 0, too. I'm at a loss!

    I assume it's something obvious. I am using the right command to get the develop branch, right? "git clone https://github.com/collectiveaccess/pawtucket2.git develop"
  • The deprecated warnings should get disabled by our setup.php. No idea why they're still showing. Hard to tell without having access to your setup.

    You can clone a specific branch like so:

    git clone -b develop <git-url>

    If you want it in a directory that's not called "pawtucket2" (say, "frontend"), you can add that as second parameter -- which is what you did with "develop" in your example:

    git clone -b develop <git-url> frontend
  • Thanks! I think I fixed it. I reset and reconfigured Apache to erase any errors I might have introduced and updated to PHP7. PHP7 is throwing out a new set of deprecation warnings, but whatever was interfering before is gone and I was able to turn display_errors off.
  • If it's still throwing warnings they will end up in your apache log file. You may want to keep an eye out for their size. They can fill up a big disk in a hurry.
Sign In or Register to comment.