Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

locale

What is the way to make Pawtucket aknowledge the localeid, when printing the metadata attributes? It prints them in English, no matter the locale specified in the field.

Comments

  • Hi,

    To change the display locale in Pawtucket all you should need to do is set a "lang" parameter on any URL to the desired locale code. For example: http://mysite.com/index.php/Front/Index/lang/es_ES would reload the front page of your site using the Spanish locale. http://mysite.com/index.php/Front/Index/lang/en_US would reload it using US English. Once set the language setting will persist for the length of the session.

    Both application strings and catalogued content will be output in the chosen locale whenever possible. That is, if you set es_ES then translatable text in your theme will be displayed in Spanish whenever possible, falling back to English for text that has no transition. A similar process is used for catalogue data. If a field has a Spanish-marked value, that will be used, with a value in another language used as a fallback if no Spanish value is defined.


  • edited September 2016
    Thanks, that did work fine for the program labels, but not so for the metadata attributes. Those get printed in English. Already checked the language attribute for the metadata, and it seems ok.
Sign In or Register to comment.