Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

full results from boolean search not working on IIS

On Windows2008 server/IIS7 using pawtucket2:

After doing a boolean search, (index.php/MultiSearch/Index?search=series_identifier:5801-01+box:53+ca_objects.folder_loc:4),  if i try to go to full results (index.php/Search/objects/search/series_identifier%3A5801-01+box%3A53+ca_objects.folder_loc%3A4)  I get a 404 error.  If I try to sort by anything,  I get no error,  but the results disappear.  Same thing with using the default theme,  so it's not that I've changed the search or browse config files or views.  It's only happening on the boolean searches.

The thing is that the exact same theme and conf files going to the same sql database doesn't have that issue on my ubuntu/apache2 instance.   I feel like I'm so close to getting this iis version working (which I need to do in order to have it public-facing).  Any assistance or ideas on where to look would be appreciated...    

Comments

  • Sounds like the search is not being escaped properly when it's used to reload the results in a different state. Sounds like a bug, but it might be IIS-specific. File a JIRA for it and we will investigate further.
  • Thanks,  it was an escaping issue.  IIS has to have double escaping enabled.  For reference if anyone else needs it,  you just add to the web config file:

    <system.webServer>
    <security>
    <requestFiltering allowDoubleEscaping=”true” />
    </security>
    </system.webServer>
Sign In or Register to comment.