Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Providence 1.7 pdfs can't see in viewers

edited May 2017 in Troubleshooting
Windows 2012/IIS 8.5/php7

Uploading pdfs from scratch in 1.7,  I get the small preview images that ghostscript makes,   but nothing is loading in the viewer.  It will download the original file from the edit page, but not the viewer. 
I've alternated using the don't use imagemagick and zendpdf in the app.conf

Looking in the media folder,  I can see the various large, mediumlarge, medium, small,  page etc  images for that pdf. 

I've tried the default mirador which just loads blank.   UniversalViewer tries to load and says not found.  TileViewer will show the first page,  but obviously it's not an option to use. . 

when I add   use_universal_viewer_for_image_list_length_at_least = 3  in the media_display,  I get this error: 

2017-05-02 16:21:10 - ERROR --> ApplicationException: Invalid viewer

Any suggestions are appeciated. 

Gmagick Provides image processing and conversion services using ImageMagick via the PECL Gmagick PHP extension
Didn't load because Gmagick is not available
RAW image support is not enabled because DCRAW cannot be found

Not available
GraphicsMagick Provides image processing and conversion services using GraphicsMagick via exec() calls
Didn't load because Imagick is available and preferred

Not used
ImageMagick Provides image processing and conversion services using ImageMagick via exec() calls to ImageMagick binaries
Didn't load because GraphicsMagick is available and preferred
Didn't load because Imagick is available and preferred

Not used
Imagick Provides image processing and conversion services using ImageMagick via the PECL Imagick PHP extension
RAW image support is not enabled because DCRAW cannot be found

Mesh Accepts files describing 3D models
Office Accepts and processes Microsoft Word, Excel and PowerPoint format documents
cannot be found: conversion to PDF and generation of page previews will
not be performed; you can obtain LibreOffice at

PDFWand Provides PDF conversion services using ImageMagick or the
Zend_PDF library. Will use Ghostscript to generate image-previews of PDF
PDFMiner cannot be found: indexing
of text locations in PDF files will not be performed; you can obtain
PDFMiner at

QuicktimeVR Provides services for processing of QuicktimeVR files
Spin360 Accepts ZIP archives containing 360 spinnable images in SpinCar format (
Video Provides ffmpeg-based video processing
MediaInfo will be used to extract metadata from video files.

XMLDoc Accepts and processes XML-format documents
BinaryFile Accepts any file unrecognized by other media plugins and stores it as-is
Not available


  • Do you have a custom media_processing.conf file?
  • edited May 2017
    I've tried leaving as is and also thought maybe it needed the tiles and tried adding the tilepic to the pdf processing,  but that creates an error. ("File could not be processed for media; can't convert mimetype 'image/tilepic' to extension") 

    It's also not picking up the OCR. 
    All the other files,  excepting word docs (after adding LibreOffice),  seem to work in the viewers. 

    I've also double-checked through all the files mentioned in the windows specific installation to replace the /dev/null.  

    I also just switched to the 1.7.1 just to see and there's no difference. 

  • Did this work in 1.6?
  • edited May 2017
    Yes--It was all working on 1.6.  If I go back to 1.6 (on the same server) even with php 7 it still works. 
  • You might want to try reprocessing all PDF media using caUtils. I suspect the previews are missing is the problem, but I'm not sure as any new files should have them.
  • edited May 2017
    It's making all the files that I can see.  I've attached a screenshot below.  

    I have it picking up the ocr now(had the path with backslashes).  

    How do you run caUtils in windows?

  • Running caUtils reprocessing the media got rid of the unknown object error,  but now the viewer tries to load and just freezes in chrome or spins forever in firefox.
  • I just noticed that when I upload pdf's now, they upload as Format:Binary File.
    ...and they also do not show in the viewer...anymore
  • I had that happen once as I was switching from imagemagick to graphicsmagick--I had forgotten to change the environmental variable of MAGICK_HOME to graphicsmagick.   That fixed it for me.  
    Still no luck on the pdfs.  Wish I knew what files it was looking for so I know if they are being made...

  • I am experiencing the same: I get "Not found" message, then spinning forever both in Firefox and in Chrome, and not loading pdf. However the site is on Whirl-i-Gig's server.
  • Lazlo: send me examples of where this is happening on your site and we'll try to resolve it. 

    Bruce: if PDFs are being picked up as binary files, it means you have binary enabled but PDF disabled. Look at the system configuration screen and try to figure out why the PDF processing plugin is not available.

    Sarahs: The IIIF viewers (Mirador and UniversalViewer) are trying to load tiles via the IIIF server that is built into CA. They're not trying to load actual files from disk. If the tile response is not what they expect (Eg. the info for the PDF indicates no tiles are available) both viewers tend to behave badly. Try editing media_display.conf to use another viewer for PDFs. If it's set to UniversalViewer (looks like that in your screen shots) try Mirador. 

    If that doesn't help, please send me a sample PDF or two and I'll test it and attempt to get to the bottom of all of this.
  • I've tried both Mirador and UniversalViewer.  The only one I can get to work is the TileViewer.  I've tried uploading to the demo to see if was anything with my particular files, and it didn't have any issues.   

  • I'm having the same problems with PDFs as Sarah.  I've tried changing between Mirador, UniversalViewer, and TileViewer.  TileViewer will show the first page of the PDF as just a jpg.  When clicking on the download icon a jpg 72px x 72px gets downloaded.  When trying Mirador and UniversalViewer the metadata info loads, but the respective viewers end up freezing the browser (Firefox + Chrome.)
  • Milo, whar version of CA are you running?
  • How did this all shake out for everyone did it resolve?

  • It hasn't for me.   There was also someone on the chat room that had the same problem last month (both of us were using windows server 2012 R2 --using both apache and iis).  They said they'd look into it, but it was right before the holidays so they probably haven't had a chance yet.  
  • edited July 2018

    Does anyone know if this has been resolved? My version of providence isn't recognizing PDFs for me either but instead taking them in as binary files even though in my configuration binary files seem to be disabled. (screenshots of configuration attached)

  • My issue hasn't. I've brought it up on the chat a few times and they've started working on it, but haven't had a chance to get to it yet. I recently reminded them.

    It sounds like you have a slightly different issue. I've had some pdfs that were badly formed that it would only take as binary files. When I ran accessiblity fixes and saved as pdf/a, it would then take them. I have it now where it will extract the text, create a thumbnail, but the viewer doesn't work.

  • Interesting. I've never gotten a viewer or a thumbnail to work. I'll play around with reformatting pdfs and see if that helps.

  • Hi everyone, we have hit this exact same problem. We have just uploaded 2000 (locally working) PDFs, and the majority of them are appearing as 'binary' in CA, and thus not rendering or usable. I am now running Acrobat to batch upgrade to PDF/A (as this was suggested as a solution in another Discussion, and works with a sample test), which is fine.

    However, what's the best, easiest way to replace all the PDFs? I didn't (and now wishing I did) put all the PDFs I uploaded into a Set. Is there a way to create a Set of all PDFs, or ideally all binary files? Then I could mass delete and just upload.

    Otherwise, I have to go through thousands of objects and manually delete the corrupted files, then upload, which will take days of work.

    Anybody got a good idea of how to quickly mass-replace the PDFs? Thanks for any help.

  • If you have a standard prefix in your naming covention you could use ca_representations.original_filename. Since the wildcard only works at the end of the string for CA, the next best way i can think of would be to go straight into mysql so you can use regex to get the idnos or exporting to excel and filtering with text contains on the filename to pdfs and then make a data import mapping into an internal field to create a set.

  • Hi Sarah, thanks for this, but I actually figured it out a few days ago (I should have updated the Discussion, sorry) - I went to https://(domain)/providence/index.php/find/SearchObjectRepresentations/Index (found through a bit of hacking/guessing) and entered this into the search field:


    (again found with some creative thinking). This showed all the binary files in one hit, so I can them add them to a Set and mass delete. Works a charm once you know how. Cheers, P

Sign In or Register to comment.