Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Pawtucket2 Installation Path to Media Directory Wrong

System configuration error detected see below. The server seems to be writing the path to the media directory twice and i've tried changing the settings in the global.conf as suggested in the installation directions:
ca_media_url_root =/digitalcollection/media/<app_name>
ca_media_root_dir =/home/myusername/public_html/digitalcollection/media/<app_name>
but it still seems to be doing something strange. Permissions are 777 on media directory. Pawtucket2 is in a directory called "display" in the Providence directory named "digitalcollection". Any suggestions on how to fix the issue?


It looks like the media directory is not writable by the webserver.
Please change the permissions of
/home/myusername/public_html/digitalcollection/display/home/myusername/public_html/digitalcollection/media/digitalcollection
(or create it if it doesn't exist already) and enable the user which
runs the webserver to write this directory.

Server Info
Apache Version     2.4.25
PHP Version     5.6.30
MySQL Version     5.6.35
Architecture     x86_64
Operating System     linux

Comments

  • edited May 2017
    Update: if i hack the Pawtucket2 ConfigurationCheck.php like below it does report all my permissions are set to 777, so it's not really a permissions problem, for my media files and it then tries to run Pawtucket2 but none of the images will load and all have broken links symbol.

            $vs_media_root = '/home/myusername/public_html/digitalcollection/media/digitalcollection';
            echo substr(sprintf('%o', fileperms('/home/myusername/public_html/digitalcollection/media/digitalcollection')), -4);

    Any suggestions?
  • Post your setup.php file please. You have an incorrect path somewhere. It's not a permissions problem despite the error message text. The OS is returning the invalid path a "unwritable" – which it is of course. Fixing the path should resolve the issue.
Sign In or Register to comment.