Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

numeric range field search working in providence, but not pawtucket

Providence 1.7, pawtucket2--both running on the exact same server, database.

I have a field that I can do a range search in providence,  but I get no results in pawtucket .  I've checked that the search indexing config for that field is the same and I've tried the advanced search with the field, and both the access point and the full field name such as ca_objects.numeric_id:[29000 to 29030]   in the search box.  I've checked that all the items are public accessible as well.   There must be something I'm overlooking, but I can't see what it is.  

Comments

  • Your search indexing settings may be blocking the brackets.  Have you tried using quotes?
  • edited June 2017
    Quotes didn't do it either....  Brackets are working on other fields--must be something in that particular field that isn't right.  
  • I accidentally added an extra bracket at the beginning ca_objects.numeric_id:[[29000 to 29030]    and it worked.   So there must be something that is set where the left bracket needs to be escaped.  

  • Hmm... and no custom search.conf config right? Can you file an issue for this on JIRA (http://clangers.collectiveaccess.org)


    thanks
    seth
  • No, no custom search.conf.   Will do. 
  • Ok I found the problem and fixed. It's in GitHub/develop and will be rolled into the 1.7.4 release. The relevant JIRA issue is http://clangers.collectiveaccess.org/jira/browse/PAWX-109
Sign In or Register to comment.