Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Media Import suddenly stops.


I am trying to upload images into CollectiveAccess using the "Media import" tool in Providence. It starts importing ok but it stops importing after 10 or so images.

I have tried reinstalling Providence and using different settings for importing.

I am also wanting to change the directory that the media importing tool uses. But I can't find the line of code in "app.conf" to do this. 

Any help would be appreciated.



  • The app.conf setting is: batch_media_import_root_directory =

    What happens when the import stops? Have you tried with other images, or just this set? 
  • Would you happen to be pulling the images off of a network attached storage device? Like a Synology box?
  • Hi Julia,

    No I have no tried with other images yet I will try that now. 

    The import simply just stops and does not progress any further, it just sits there. I can tell the import has stopped because the page loading circle goes away in the tab bar. When an import has been successful the page is continuously loading in my experience.

    Since posting my initial comment I went into the php.ini file and changed the "post_max_size" and "upload_max_filesize" to 100M as I thought that one of the images might have been bigger than the values specified. Are these values for single files or the whole folder?

    Thanks again for your quick reply I really appreciate your help.  
  • Hi Seth,

    To my knowledge I am not pulling the images off of a network storage device. I am using XAMPP running on Windows 8.1. At this stage my team and I are just trying to figure out how to import into Providence locally before moving onto running it on a Linux server.

    Thanks for your help
  • Hi Julia,

    I tried importing with some other images and it works fine. Do you have any ideas about what may be causing CollectiveAccess to stop importing with the images that I want to use?

  • Hi  connora, I am very new to collective access, and thus make every possible mistake. I finally figured out what 1) prevented any import, 2) stopped in the middle of importing.
    My problem was in the php.ini file where the memory_limit was set to 8mb.
    I checked the php_error.log
    "PHP Fatal error:  Allowed memory size of 1073741824 bytes exhausted (tried to allocate 53248 bytes"

    1) After changing it to 1024, half my images were loaded, then it stopped.
    2) After resetting the memory to 2048 all my 18 images were imported.

    Hope this helps

  • Here's another thing to try: in app.conf set 

    dont_use_exif_read_data =1

    Some media will have very large EXIF data blocks which can cause PHP to choke and issue a memory exhaustion error.
  • Thanks BCHSDA I found out the same thing as well from a friend.
Sign In or Register to comment.