Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

Providence 1.7.3 & 4 hangs at installing 'table for entity names'; error: specified key too long


After installing Providence on a local XAMP-server as well as on a Raspberry PI 3 LAMP-server I thought it was time to step it up. A real server.

  • Installing Providence 1.7.3 and 1.7.4 on a server hangs at: Installing database table for entity names (see attached file)
  • The error.log file on my server shows the following error: "[error] PHP Fatal error: Uncaught DatabaseException: Specified key was too long; max key length is 767 bytes in /var/www/vhosts/83/288621/webspace/httpdocs/" 
Software used: 
  • Providence 1.7.3 as well as 1.7.4
  • Apache 2.2.11 (Unix)
  • PHP 4.4.9 mod_ssl/2.2.11
  • phpMyAdmin 4.0.9, latest stable version: 4.7.3
  • InnoDB is enabled
Try to resolve the issue with:
  • I have tried installing different Providence versions on my server.
  • I have tried creating new MySQL databases/users on my server.
  • I have tried installing different profiles: Testing profile, VRA Core 4.0 among others

What could I do next to try to resolve the issue? Thank you very much for your help!!


  • Argh, this has to do with a limit in MySQL and character sets. Attached is a modified MySQL schema for the installed. Uncompress it and drop the file (named "schema_mysql.sql") into install/inc/

    Then rerun the install and let's see if it works...

  • @SethThanks for getting back to me so quickly!

    I have tried your suggestion, by overwriting the schema_mysql.sql-file in the install/inc folder. I then ran a new installation of Providence 1.7.4. Unfortunately it still hangs at Installing database table for entity names.

    I checked out the error log, and it shows the same message: [Sat Aug 5 16:15:52 2017] [error] PHP Fatal error: Uncaught DatabaseException: Specified key was too long; max key length is 767 bytes in /var/www/vhosts/83/288621/webspace/httpdocs/

    Really appreciate your help!
  • Ok try this one more time... drop the attached in place and reinstall.
  • @seth. This is absolutely wonderful. The installation was smooth sailing. I got Collective Access 1.7.4 up and running. Thank you very, very, much.
  • Ok great. Now I know what to change and commit :-)
  • @seth. excellent! Happy to be able to help a tiny bit!
Sign In or Register to comment.