Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

ImageMagick; uploaded resized images wash away from color

edited August 2017 in Troubleshooting
Issue (August 12): When I upload images through Imagick/ImageMagick the images wash away from color on my web server. The original photo gets uploaded properly to my server, but the resized copies get that faint color. See attachments for original sample and faint resized copy. It is related to this message (

I have uploaded the same images on my local LAMP-server (running on a Raspberry PI 3), and the images have been uploaded perfectly. The local LAMP-server uses the GD library, instead of using ImageMagick (for overview of the Media Processing Plugins for the Lamp-server as well as the web server see attachments). 

I concluded that ImageMagick might be troublesome here.

What I have tried:
  1. How can I resolve the images ashing away from color?
  2. Is there a way to disable ImageMagick and revert to GD within Collective Access/Providence?
  3. Is there a workaround?
  4. OR....... can it be that the ImageMagick library is getting called incorrectly, and that instead the GD-module is kicking in. Which then resolves in a known issue of washing away the color?
Thanks for your help! 

As you can see much appreciated (again), since I have no clue how to resolve this...

UPDATE (August 14): I have contacted my web hosting company.. They suggested to try use the GD-module instead of ImageMagick just to see how it affects the issue. The company noted that this is an issue within CA. Because I am using shared web-hosting I can't make changes on the server side. I have to make changes within the CA-configuration to use the GD-module instead of ImageMagick. Wonder how I do that..


  • I have found a solution to my own problem, and I want to share the solution in case people run into the same thing. In order to get rid of the faded effect you should disable your image media plugins and revert back to the GD plugin. In my case I had to disable Imagick, ImageMagick and GraphicsMagick.

    1. In the file mediaPluginHelpers.php located in /app/helpers I set the values of the various plugins to false. If anybody wants the php-file I can send it to you.
    2. Next, I edited the app.conf configuration file according to the following post ( and set dont_use_imagick to 1.
    3. When you have accomplished this you could check in providence>manage>administration>configuration check if you successfully disabled the various media plugins and it is using the GD module.
    4. The GD-module is using a lot more memory, so initially I got the error: Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 8192 bytes) in /var/www/vhosts/83/288621/webspace/httpdocs/ on line 1517. 
    5. I then edited the php.ini file and increased the memory_limit.
  • Hi Vincuuu_ can you send me or attach the corrected mediaPluginHelpers.php?


  • Hi,
    I had the same problem.
    Application Version:  1.7.5
    Schema revision:      147
    Last change log ID:   5689
    Imagick                  3.4.0RC6
    GraphicsMagick         1.3.23 2015-11-07 Q16
    OS Ubuntu 16.04.04
    When uploading or importing images, the colours appear washed out compared to the original.
    There is a problem with Imagick so the solution is to roll back to another image processor.
    The next default image processor in the default hierarchy is
    GraphicsMagick, so by disabling Imagick, GraphicsMagick will become the
    default processor.
    Edit the app/conf/app.conf
    sudo nano app/conf/app.conf
    Find the setting dont_use_imagick = 0
    Change to dont_use_imagick = 1

    Save and close.
    Reload apache2
    sudo service apache2 reload
Sign In or Register to comment.