Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

(SOLVED) Images doesn't save in media folder

edited December 2017 in Pawtucket

I'm creating an object and I'm associating images. The images are visible in Providence with status completed and public access. When I view Pawtucket the image doesn't appear, I see an error in the browser console informing me that the image isn't on the server. When I go to the server, the image hasn't really been saved. When I save to Providence, no error appears.

In the configuration file global.conf in Pawtucket, I have the following:
ca_media_url_root = <ca_url_root>/media/<app_name>
ca_media_root_dir = <ca_base_dir>/media/<app_name>

The files are organized on the server as follows:

Do you know what that might be?

Thank you in advance for your answers.


  • edited November 2017
    I already solve. It needed to create a symbolic link from the Providence folder to the Pawtucket folder. I executed the following command:

    cd pawtucket

    sudo ln -s /var/www/ca/providence/media

  • edited November 2017
    hi, i too am having this problem, but when i go to run the above command i get the following message:

    effective uid is not 0, is sudo installed setuid root?

    any idea what to do next? i am working from MacOS terminal SSH into Bluehost

  • I made this little utility to help manage the links to the media directory on a shared server I'm using.  It resolves my lack of command line access.  Maybe useful?
  • Are you trying without sudo?

    ln -s /var/www/ca/providence/media
  • Hi Ruth,

    When I tried without sudo, this is what I received: "file exists"

    not sure if that means it worked?  have a feeling thats not what it means, haha. I had created an empty media/collectiveaccess folder under pawtucket in order to get it up and running, maybe i should delete that?
  • Try symlinking the "collectiveaccess" directory within. Or remove that empty "media" directory in Pawtucket and then try symlinking the "media" directory from Providence again. Either way should work.

  • alexandradm ,

    Do you have a media folder in Providence? Hope so (providence/media)

    You should now go to the pawtucket folder:
    cd pawtucket

    In this folder there should not be a media folder. This is where the symbolic link must be created, creating a link from the providence/media folder to the pawtucket/media

    sudo ln -s /var/www/ca/providence/media

    Everything that is saved in the providence/media folder will appear in pawtucket/media. This works as a shortcut
Sign In or Register to comment.