Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

(SOLVED) Debugging metadata elements that don't appear in Pawtucket2

edited December 2017 in Pawtucket

I am struggling with displaying some fields in our frontend (which only exists locally). I was wondering if anyone had any tips for debugging the display of metadata elements on the frontend?

For example, for ca_occurrences.description, which is a container field, I am trying to dip down into ca_occurrences.description.another_container.container_text (for example, mirroring how it is set up in Providence) but it displays nothing. And ca_occurrences.description is repeating the description text field once, and then printing the source field (which is also in the top-level description container). Why does it do this!

It ends up displaying like this: "description of the Work; description of the Work;source of description"

I am used to working with JavaScript, not with PHP. Is there a way to print all of the potential elements on the page so I can see if there is something wrong with the array, and try to understand why I cannot just grab the field, as seems to be possible with other fields, such as address?

Are there other ways to debug the connection between the backend and the frontend, to figure out if it is a permissions or accessibility issue instead?

Thanks much!



  • Hi,

    When addressing sub-fields in a container the syntax is <table>.<container code>.<sub-field code>. No matter how many levels there are in the element hierarchy, the address is never going to be more than two levels – container, then sub-element. For your example try using ca_occurrences.description.container_text.
  • Wow, thank you! I thought I tried everything, but I did not try that, and it totally worked.

    Seems customary to update the original post with Resolved, so I will do that now.
Sign In or Register to comment.