Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

ISAD(G) profile: How to declare hierarchical elements?

I've installed CA providence (1.7.5) using the included ISAD(G) profile.
The fields are clear, but I couldn't figure out how to assign the hierarchical relationship between entries.

For example:
If I create a sub-fonds, how do I tell which fond is its parent?

There's a hierarchical navigation element in the "Identity" section, but it always says "Number of objects in hierarchy" - and just displays the currently edited entry.
I've checked the documentation on "Location in Hierarchy Bundle", but I only have the "Explore" option. No "Move" or "Add" :(
I'm logged in as user "administrator", so I guess it's not a access rights issue.

I've also tried using "Allied Material" section to declare "Related Objects", using "is part of" - but that didn't work.


Thank you very much in advance.

Comments

  • edited February 2018
    Hi peter_b

    You should create the subfonds from the parent record using the "create child record" option.  It will then be recognized as part of the hierarchy.

    You can move or add records within a hierarchy using the "hierarchy navigation" bundle (which is different from the "location in hierarchy" bundle), but you can't assign an existing record to an existing hierarchy within the UI.
  • Thanks for your answer! :)
    Unfortunately, I can't find the "create child record" option anywhere :(

    I've attached a screenshot of a newly created Fond. It shows the "Hierarchy Navigation" bundle on top - but no add/move options :(

  • Hi peter_b,

    In your app.conf file, you'll find the options to enable this control:

    ca_objects_show_add_child_control_in_inspector, ca_collections_show_add_child_control_in_inspector, etc.

    You may need to be using the "location in hierarchy" bundle instead - sorry I may have gotten them mixed up!
  • edited February 2018
    Enabled the following setting in app.conf worked:
    ca_objects_show_add_child_control_in_inspector = 1

    Thanks! :)

    Since human errors will (and do) happen, is there any way I modify the hierarchy structure of existing items (if needed)?
    You've mentioned that I cannot do that in the UI, but is there any other way?

    Thank you very much in advance.
  • Hi peter_b,

    The good news is that the hierarchy location tool has been updated and now allows you move non-hierarchical items under existing hierarchies.  Under the "Move" tab, you should be able to use the Find field to lookup the fond under which to move your item.
  • Hello Peter and Sophie.

    I am unable to find the location in hierarchy bundle screen.

    I took a look at the docs, but coundn't find it in the Editor Screen. I am trying to locate it using a Sub-fond wich is already part of a hierarchy.
    https://docs.collectiveaccess.org/wiki/Location_in_Hierarchy_Bundle

    Do we need to activate any configuration in app.conf?

    I am running version 1.7.7

    Regards.

    Tomas.

  • I think you need to adjust your isadg profile xml.
    Replace in userInterface type ca_objects the bundle
    hierarchy_navigation
    by
    hierarchy_location

  • Hi jmoest. Thanks for your reply.

    I changed the file /install/profiles/xml/isad_g.xml
    From this content:


    hierarchy_navigation

    To this content:

    hierarchy_location

    But I don't see any change in the screen I uploaded in my previous post.

    Were those steps I followed correct?
    Am I supposed to see a Location in Hierarchy screen there?

    Regards.
    Tomas.

  • edited April 22

    Your code is correct: hierarchy_location. Are you sure you're looking at the correct screen/UI?

    <placement code="hierarchy_location">
                  <bundle>hierarchy_location</bundle>
                </placement>
    
  • edited May 25

    I also have this issue. I have also made the change:

    <userInterfaces> <userInterface code="standard_object_ui" type="ca_objects"> <labels> <label locale="en_US"> <name>Standard object editor</name> </label> </labels> <screens> <screen idno="identity" default="1"> <labels> <label locale="en_US"> <name>Identity</name> </label> </labels> <bundlePlacements> <placement code="hierarchy_location"> <bundle>hierarchy_location</bundle> </placement>

    but I also cannot change the hierarchy of existing Objects in my ISAD(G) installation.

    Any ideas here please Julia?

    Thank you,

    Peter

Sign In or Register to comment.