Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

providence not generating video image, only icon

My version of ffmpeg installed is 2.8.11-0ubuntu0.16.04.1, CA 1.7.5

No problem playing. And Pawtucket do generate image instead of Icon

Comments

  • Hello Olah,
    Have you run a dmesg in command line, read the system syslog or read the apache2/error.log or apache2 log files when this was run?
    I had a similar problem, on Ubuntu 16.04 64 bit, etc. I believe the problem could come from ffmpeg due to the codec used in the media and what codecs are loaded in the kernel of the ffmpeg executable (so). What are the output from your configuration check?

    My problem was from using the ppa mpeg installed by "sudo apt-get install -y ffmpeg", This is limited in what it can play, so I built my ffmpeg from scratch, I use the /opt directory for built plugins.
    Remember you have to modify the "external_programs.conf" and set PHP "open_basedir" according to the path of the executables if you try this. If unsure, build a virtual machine and test there. Please read the script below, observe the list of codecs included in the library for ffmpeg, and check against the codec of your actual file.


    You need to be familiar with linux. My ffmpeg script here:

    #!/bin/bash

    # Check if user has root privileges
    if [[ $EUID -ne 0 ]]; then
    echo "You must run the script as root or using sudo"
       exit 1
    fi

    echo "Purpose: to build and compile ffmpeg for CollectiveAccess"

    echo "Remove ffmpeg and libraries"
    sudo apt -y  remove ffmpeg x264 libav-tools libvpx-dev libx264-dev

    echo "Build tools for server"
    sudo apt-get update
    sudo apt-get -y install build-essential checkinstall git libfaac-dev libgpac-dev \
      libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev librtmp-dev libtheora-dev \
      libvorbis-dev pkg-config texi2html yasm zlib1g-dev libopus-dev

    echo "Moving to /opt"
    cd /opt
    echo "Making required directories for ffmpeg "
    mkdir ffmpeg_sources
    mkdir ffmpeg_build
    mkdir bin

    echo "Installing required libraries"
    sudo apt-get -y install build-essential checkinstall git libfaac-dev libgpac-dev \
      libmp3lame-dev libopencore-amrnb-dev libopencore-amrwb-dev librtmp-dev libtheora-dev \
      libvorbis-dev pkg-config texi2html zlib1g-dev libass-dev
    cd /opt


    echo "Building and installing yasm compiler"
    cd ffmpeg_sources
    wget http://www.tortall.net/projects/yasm/releases/yasm-1.3.0.tar.gz
    tar xvfz yasm-1.3.0.tar.gz
    cd yasm-1.3.0
    ./configure --prefix="$opt/ffmpeg_build" --bindir="$opt/bin"
    make
    make install
    ldconfig
    cd /opt



    echo "Building and install NASM compiler"
    cd ffmpeg_sources
    wget http://www.nasm.us/pub/nasm/releasebuilds/2.13.01/nasm-2.13.01.tar.bz2
    tar xjvf nasm-2.13.01.tar.bz2
    cd nasm-2.13.01
    ./autogen.sh
    PATH="/opt/bin:$PATH" ./configure --prefix="/opt/ffmpeg_build" --bindir="/opt/bin"
    PATH="/opt/bin:$PATH" make
    make install
    ldconfig
    cd /opt


    echo "Installing Codecs, no need to build from source yet..."
    sudo apt-get -y install libx264-dev
    sudo apt-get -y install libx265-dev
    sudo apt-get -y install libfdk-aac-dev
    sudo apt-get -y install libmp3lame-dev
    sudo apt-get -y install libopus-dev
    sudo apt-get -y install libvpx-dev


    echo "Additional packages not on the server"
    sudo apt-get -y install libfdk-aac-dev libfdk-aac0 libass-dev

    echo "Installing FFMPEG sources"
    cd ffmpeg_sources
    wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2
    tar xjvf ffmpeg-snapshot.tar.bz2
    cd ffmpeg
    PATH="/opt/bin:$PATH" PKG_CONFIG_PATH="/opt/ffmpeg_build/lib/pkgconfig" ./configure \
      --prefix="/opt/ffmpeg_build" \
      --pkg-config-flags="--static" \
      --extra-cflags="-I/opt/ffmpeg_build/include" \
      --extra-ldflags="-L/opt/ffmpeg_build/lib" \
      --extra-libs=-lpthread \
      --bindir="/opt/bin" \
      --enable-gpl \
      --enable-libass \
      --enable-libfdk-aac \
      --enable-libfreetype \
      --enable-libmp3lame \
      --enable-libopencore-amrnb \
      --enable-version3 \
      --enable-libopencore-amrwb \
      --enable-librtmp \
      --enable-libopus \
      --enable-libtheora \
      --enable-libvorbis \
      --enable-libvpx \
      --enable-libx264 \
      --enable-nonfree
    PATH="/opt/bin:$PATH" make
    make install
    ldconfig
    hash -r
    cd /opt


    echo "Install qt-faststart"
    cd /opt/ffmpeg_sources/ffmpeg
    make tools/qt-faststart
    make install
    ldconfig
    cd /opt

    echo "Install complete"
    exit 0




    ##############################################

Sign In or Register to comment.