Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

List and Vocabulars errors after upgrade to CA Providence 1.7.5 from 1.6.2 [Partial solved]

edited February 2018 in Troubleshooting
Hi,
We are trying to do upgrade from CA Providence 1.6.2 to CA Providence 1.7.5

The upgraded has been done correctly, but when we started to use we noted some problems.

First, with user Administrator when we enter in Lists And Vocabulars menù in hierarchical combo we see a lot of "???" instead our labels that we can see in previous version 1.6.2 (as you can see in pictures)

Then, research not function with different users, for examples a cataloguer.
We obtain a blank screen as shown in picture, and php log show an error as you can see.

We tried also to upgrade PHP to PHP70, from PHP5.6 but we had same problems, so we returned to PHP5.6

So I tried to change only CA source code, restoring CA Providence 1.6.2 version, but leaving same db (deleting only the rows added in ca_schema_updates)
and we see Lists and Vocabulars in correct way, and also the research function correctly for other users!

We saw that this error have been fixed with this Jira http://clangers.collectiveaccess.org/jira/browse/PROV-1913 but I didnt find how you resolved it.
And at the same time, we thought that now we should see correct way.

Can you help us please?
Thanks

Luigi Montinaro
CSI Piemonte

CA - PROVIDENCE - v.1.7.5
PHP v: 5.6.33
MySQL v: 5.6.25




Comments

  • Sorry, we solved the problem of Lists and Vocabulars.

    Cleaned and reinstalled providence package 1.7.5, and then put our local configuration, now we see the correct labels.

    But we continue to have the problem on simple search from cataloguer users.

    Blank screen and in php log we have this:

    ...
    [28-Feb-2018 10:13:38 America/New_York] PHP Warning:  array_flip(): Can only flip STRING and INTEGER values! in /data/www/html/cola/app/models/ca_bundle_displays.php on line 670
    [28-Feb-2018 10:13:38 America/New_York] PHP Warning:  array_keys() expects parameter 1 to be array, null given in /data/www/html/cola/app/models/ca_bundle_displays.php on line 662
    [28-Feb-2018 10:13:38 America/New_York] PHP Fatal error:  Call to a member function nextHit() on null in /data/www/html/cola/app/models/ca_bundle_displays.php on line 665

    And the warning array_flip() is repeated a lot before give the fatal error.

    Have you got any idea?
    Thanks a lot


  • Having the same issue right now.

    Have you managed to resolve the array_flip() error?

  • It's not an error, my bad. grep -ri "ERROR_" in the app directory led me to the place where i could add disable warnings

Sign In or Register to comment.