Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

HTTPS not working properly

I recently switched from HTTP to HTTPS for the protocol that I use for my CollectiveAccess website. This seems to work, except that now every page that is rendered (including the login page) has the same warning (sometimes at the bottom of the page, usually partially visible behind the body of the page):

Warning: fsockopen(): Failed to enable crypto in /home/museumweb/ on line 617

Warning: fsockopen(): unable to connect to tls:// (Unknown error) in /home/museumweb/ on line 617

Clearly, there is a (minor?) problem. My provider (dreamhost) has no idea what the issue might be. I also run a WordPress website from the same address and I do not seem to get any warnings for that site. I have a couple questions:

* Is this a harmless issue?
* If so, is there a way to not have the warning show on each page?
* If not, how on earth would I troubleshoot this problem?



  • Does your PHP install have OpenSSL built into it? That would fix this issue. Otherwise you'll have to disable out of process search indexing, which is what is generating these failed connections. You can do that by setting  disable_out_of_process_search_indexing = 1 in your app.conf file
  • Thanks Seth. I switched back to http. I just tried https with Providence 1.7.6 and the problem is still there, although the warnings now are redirected to the Apache error.log. I am using PHP 7.0.30 with FastCGI and openSSL ( 6) enabled --Eisso

  • This is still a problem with https even when disable_out_of_process_search_indexing = 1?

  • No, everything seems to be working fine now, although I am still not sure what exactly out of process search indexing does? Thanks, Eisso

Sign In or Register to comment.