Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Container presets?

On an installation with VRA profile, I've seen a drop-down for "Presets" in containers.
For example "measurementSet" or "descriptionSet".

How can I configure/define such presets?
I couldn't find it in the Wiki - nor any configuration when editing these metadata element containers (or their sub-elements)

Thank you very much in advance.

Comments

  • I'm not sure what you mean by "presets" -- could you provide an example? Are you referring to the drop-down lists within the contaienrs?
  • Yes, the drop-down lists in the top-right corner of containers (see screenshot).
    Thanks :)
  • edited March 13
    You can edit these in attribute_presets.conf at providence/app/conf/attribute_presets.conf
  • I've tried adding new measurement sizes to "attribute_presets.conf".
    Works, but I ran into the problem that none of the presets populate the fields correctly :(
    So I've reported issue #2397.

    Or maybe I'm using it wrong?
    I couldn't find documentation, just a mentioning in issue #514 (from 2013).

    btw: I'd be happy to contribute a preset list for the DIN paper formats :)
    If you're interested to get it upstream: what would be your preferred way?

    Thanks in advance :D
  • per your JIRA...the values below (i.e. measurements, measurementTypes, etc.) must match the configuration of the sub-elements of the container you are using in your metadata element.
    measurements = 8.5 in., 
    measurements2 = 11 in., 
    measurementsType = width, 
    measurementsType2 = height 
  • edited March 28
    I know - and I've checked :)

    I've reported this, because these are the configurations for the VRA Core profile (config file and metadata elements) that come with CA.
    And they seem to be incorrectly configured.

    But apart that there's no 2nd field (measurements2, measurementsType2), it's also so that only the first field in the list (measurements) is set by the preset. "measurementsType" is not set, but shoudl be (if I understood it correctly).

    Just wanted to check if I'm using it wrong, or if it's something else?
    Thank you very much again :)
  • This isn't meant to match the VRA Core profile configuration...it's meant to be set to match each custom config (sorry, maybe I'm still not understanding what you are saying here?)

    If you don't have a second field, please send on details about how your measurements container is configured and we can confirm if it will work for your set up.
  • Sorry if I've caused confusion :D

    Shall we continue this here, or rather in the bug-report (on JIRA), since I still believe that something's not working properly?
  • Sure we can move this over to JIRA but please include the details about the metadata element in your configuration because that's the only way to know if this is a bug or a mistake in how it's been set up.
Sign In or Register to comment.