GraphicsMagic doesn't generate Images

edited April 2018 in General Support
Hi
My shared hoster provides GM and says it works. I enabled GM and the configuration of CA 1.7.5 shows it is available (green). But uploading any Image (which works with GD) results in showing only a grey placeholder. In the media folder there is only the original image. What could this cause? Is there any way to show error logs of GM? I'll attach the gm version shell output.

edit: I tested a gm convert with ssh on the server which works perfect - so I wonder where's the problem.

edit2: next to the placeholder ca writes that the jpg is a binary file

thx, Olivier

Comments

  • I did a fresh install of ca 1.7.5. and tried every plugin. The Result is:

    Imagick: washed out colors
    GraphicsMagick: No image
    ImageMagick: No image
    GD: works

    Every plugin was green and available in configuration check.

    GM definitely works on the server when calling it directly via ssh.

    Thats weird...

    Olivier
    752 x 587 - 29K
  • edited April 2018
    I now was able to output a error log just of the action of uploading the image. See attachment. Does this help finding the cause?

    could this be the problem?:

    [10-Apr-2018 16:22:45 America/New_York] PHP Warning:  exec() has been disabled for security reasons in /home/tsttld2/public_html/app/helpers/mediaPluginHelpers.php on line 103
    [10-Apr-2018 16:22:45 America/New_York] PHP Warning: exec() has been disabled for security reasons in /home/tsttld2/public_html/app/helpers/mediaPluginHelpers.php on line 103
    [10-Apr-2018 16:22:45 America/New_York] PHP Warning: exec() has been disabled for security reasons in /home/tsttld2/public_html/app/helpers/mediaPluginHelpers.php on line 103

  • exec() has been disabled in php.ini. Are you on a shared server by chance?

  • Yes, it is a shared server....
  • Your host most likely has disabled that function.You will need to work with them, but they may or may not enable it for you.
  • Thx for your help! I could enable exec in the hoster config and now it runs!!

    Thx again,
    Olivier
Sign In or Register to comment.