Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Pawtucket Cache Management / High CPU usage

Providence & Pawtucket: 1.7.5

I'm having an issue where my server resources are being gobbled up by dozens of apache2 processes maxing out CPU usage.  When I strace them it appears that all these processes are trying to open files in the /pawtucket/app/tmp/Cache folder.  The result is a ton of Close_wait connections tied up rendering the site unable to load.

When I looked at the cache folder, it was very large and contained cache from several months ago.

content_caching.conf has a setting of objects = 86400

Shouldn't cache older than 86400 be removed?

Is there anything else that I am missing or any suggestions how to manage this.



Comments

  • edited May 2018
    How do you disable caching:  my app.conf has do_content_caching = 0

    Are there any other steps to refresh cache other than clearing the folder?  It doesn't appear that the cache is expiring and deleting so the tmp cache folder if growing quite large.
  • I resolved this issue with the following:

    We have replaced following code in /pawtucket/index.php

    $resp->addHeader("Cache-Control", "no-cache, must-revalidate");
    $resp->addHeader("Expires", "Mon, 26 Jul 1997 05:00:00 GMT");

    with the following code:

    $resp->addHeader("Cache-Control: no-cache, no-store, must-revalidate");
    $resp->addHeader("Pragma: no-cache");
    $resp->addHeader("Expires: 0");

    The change is made between line no 113 to 117.

Sign In or Register to comment.