Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Can't get metadata separator displayed in pawtucket 2

Hi all,

I'm sorry for bothering you since this should be clear to me from your documentation, but unfortunately I couldn't get it working yet. So, in pawtucket2 at the object detail view I want to show a metadata-element which contains multiple values and those values should be properly separated. It looks like this right now: https://mediathek.museumsstrasse.at/index.php/Detail/objects/13
where at 'Schlagwörter' (=keywords) you can see that the multiple values are separated by semicolons but without space which makes it not very pretty.


I tried to follow your documentation here: https://docs.collectiveaccess.org/wiki/Display_Templates#Placeholder_options where there is a line shown like this:
^ca_objects.hierarchy.preferred_labels.name%maxLevelsFromBottom=4&delimiter=_➜_

So from my understanding the '&' indicates some options on how the metadata-element is displayed, so I tried the same in our ./views/Details/ca_objects_default_html.php where currently it looks like this:
{{{<ifdef code="ca_objects.S_schlagwort">
                                        <p>SCHLAGWÖRTER: ^ca_objects.S_schlagwort</p>
</ifdef>}}}

(S_schlagwort is the identifier for the text-metadata element)

Triying things like
SCHLAGWÖRTER: ^ca_objects.S_schlagwort&delimiter=_➜_
or
SCHLAGWÖRTER: ^ca_objects.S_schlagwort%delimiter=_➜_

and many other variations didn't work.

Can you point me please to the right direction?

Cheers,
Stefan

Comments

  • In case our instance wouldn't display anything since I'm reworking a few things, I've attached a screenshot of the values not being separated with additional spaces to the semicolons.
    tmp.jpg 304.7K
  • Hi Stefan.  Either of these should work to separate repeating elements with ", ":

    ^ca_objects.S_schlagwort%delimiter=,_

    <unit relativeTo="ca_objects" delimiter=", ">^ca_objects.S_schlagwort</unit>
  • Hi Maria,

    the first option did not work, but the second one with <unit ... > did the trick. 

    Thank you very much!

    Stefan
Sign In or Register to comment.