Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Prepopulate.conf: ignored?

edited July 2018 in Installation

I'm trying to configure the prepopulate plugin, but it seems like "nothing's happening".

On v1.7.5 (git), the config file is located in: /app/plugins/prepopulate/conf/prepopulate.conf
But the documentation says it should be: /app/conf/prepopulate.conf
I've tried to move it to "app/conf", but still: nothing happens.

Is there any logfile I could check to see if my rules are applied at all?

Thank you very much in advance :)

Comments

  • My file looks like this:

        # set to 1 to enable the plugin
        enabled = 1
    
        prepopulate_fields_on_save = 1
        prepopulate_fields_on_edit = 1
    
        prepopulate_rules = {
                # -------------------
                cws_event_name = {
                        table = ca_occurrences,
                        #restrictToTypes = [artwork],
                        mode = overwrite,
                        target = ^ca_occurrences.preferred_labels.names
                        template = Test-1-2-3
                },
                # -------------------
        }
    
  • If you navigate to another screen and then navigate back does the value pre-populate? See: http://clangers.collectiveaccess.org/jira/browse/PROV-2497

  • Will try!
    Thanks :)

  • First of all: Typo in my rule! :blush:
    There's a "," missing at the end of the "target=" line.

    But I can't get it to overwrite the preferred_labels field.
    Other fields yes, but not this one.

    Any ideas?

  • Try "name" singular.

  • Thanks Julia!

    I've also set the preferred_labels field to "read only".
    Works like a charm :)

    Here's the working ruleset:

    cws_event_name = {
                    table = ca_occurrences,
                    restrictToTypes = [cws_event_ipr],
                    mode = overwrite,
                    target = ^ca_occurrences.preferred_labels.name,
                    template = ^ca_occurrences.cws_RegionalScope (^ca_occurrences.cws_Date)
            },
    
Sign In or Register to comment.