Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Browse facet count are all (1)

Hello,
We created two lists for our objects: "Object Materials" and "Publications". However, when we added them to the browse.conf, the item count in the facet list are all 1 even though we have more than one record with these values. If you click one of the facet values, it does show the correct number of results.

Our browse.conf for these:

material_facet = {
type = attribute,
element_code = materials,
group_mode = none,
label_singular = _("object material"),
label_plural = _("object materials")
},

publication_facet = {
type = attribute,
element_code = publication,
group_mode = none,
label_singular = _("publication"),
label_plural = _("publications")
},

I've tried other facet types, and they don't display. Group mode alphabetical vs none also doesn't make a difference.

List basic info from Providence:

Application version: 1.7.6
Browser: Chrome Version 67.0.3396.99, Internet Explorer 11.0.9600.19002

Comments

  • Hi Elizabeth,
    Is your test site ignoring access values, and are your records marked as "accessible to the public"? Have you tried rebuilding your search index and emptying the contents of your app/tmp folder?

  • Hi Sophie,
    I'm not sure how to tell if my site is ignoring access values. The majority of our records are accessible to public. In the above example, we have 5 objects with "lithium-iodine batteries" object material accessible to public, but the browse facet count is (1). I tried rebuilding my search index, but no luck. Which app/tmp folder should I be emptying, providence/app/tmp or pawtucket/app/tmp? And does that include the /app/tmp/collectiveaccessCache subfolder?

  • Hi Elizabeth,
    You should clear pawtucket/app/tmp and the subfolder.

  • Hi Sophie,
    That didn't seem to work. We've decided to not display the counts for the facet list. Thanks for your responses.

  • Hi Elizabeth, how do you get the item count to show in Pawtucket2? Thanks!

  • Make sure you're using the latest code if possible.

  • edited January 24

    I’m using Pawtucket Code from November 2018 and it’s working for some facets but not for facets with the type = attribute,. Any idea on how to fix this?

    Working:

    Not Working:

  • I would have to see your browse.conf file and data to tell you.

  • edited February 25

    Here is my themes browse.conf: https://transfer.sh/kRwwH/browse.conf

  • Would it be possible to turn the display of counts off somehow?

Sign In or Register to comment.