Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Pawtucket 1.7.6 BrowseEngine.php

I haven't been able to get browsing to work on version 1.7.6. When I select the browse link, I get an error message stating the sql syntax has an error in queries such as this:
SELECT COUNT(*) _count, * FROM ca_object_lots INNER JOIN ca_objects ON ca_objects.lot_id = ca_object_lots.lot_id INNER JOIN ca_object_lot_labels AS lab ON lab.lot_id = ca_object_lots.lot_id WHERE ((ca_objects.access IN (1))) GROUP BY ca_object_lots.name

It seems like the issue is that the "group by" value - ca_object_lots.name - isn't a valid table column. The code setting this value is around line 4036 of /pawtucket/app/lib/ca/Browse/BrowseEngine.php. It seems like the right group value could be ca_object_lot_labels.name, but I'm not sure how to update the code to affect that.

Comments

Sign In or Register to comment.