Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Search indexing not automatic. Trying Redis gives error messages.

edited September 2018 in Troubleshooting

Software version: Providence 1.7.5
Browsers: Latest Chrome (64.0.3282.186) and Firefox (58.0.2) versions
Profile: An adaptation from the SPECTRUM profle

I am having trouble with search indexing.
In my local installations after adding an object or entity for instance, the object or entitity is (almost) immediately found with the quick search (upper right hand search box)
In my shared-hosted installation a new object, entity etc is only found after manually rebuilding the search indexes, either via the UI or caUtils.

Is there a setting in Setup.php or any other file that I may have messed up?

The host supports redis so I tried to set the installation up to use it.
I changed the setup.php like this:

line 187: define('__CA_CACHE_BACKEND__', 'redis');
line 235: define('__CA_REDIS_HOST__', 'xxx.xxx.xx.xx');
where xxx.xxx.xx.xx is the IP adress for the redis database supplied by the host
line 239: define('__CA_REDIS_PORT__', xxxxx);
where xxxxx is the port number for the redis database supplied by the host

If I apply this setup I get a HTTP error: HTTP ERROR 500

If I try caUtils to rebuild the search index i get the following error messages:

PHP Fatal error:  Uncaught exception 'RedisException' with message 'Failed to AUTH connection' in /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Cache/ExternalCache.php:245
Stack trace:
#0 /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Cache/ExternalCache.php(245): Redis->select(0)
#1 /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Cache/ExternalCache.php(194): ExternalCache::getRedisObject()
#2 /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Cache/ExternalCache.php(52): ExternalCache::getCacheObject()
#3 /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Cache/ExternalCache.php(137): ExternalCache::init()
#4 /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Configuration.php(985): ExternalCache::contains('ConfigurationCa...')
#5 /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Configuration.php(146): Configuration::loadConfigCacheInMemory()
#6  in /home/u31667p26800/domains/radboudkunst.nl/public_html/testrb/app/lib/core/Cache/ExternalCache.php on line 245

Comments

  • First of all, set CA_CACHE_BACKEND to "file" to get rid of the REDIS errors. That can be figured out later. Then in app.conf set disable_out_of_process_search_indexing = 1 and see if that helps with the search indexing.

  • Hello Seth,

    I had already set CA_CACHE_BACKEND back to "file" because it did not work. Could that be because the provider has set a password for the REDIS database?

    In app.conf disable_out_of_process_search_indexing was already set to disable_out_of_process_search_indexing = 1.
    Therefore I had changed it back to disable_out_of_process_search_indexing = 0 based on another post/solution.
    I will set it back to disable_out_of_process_search_indexing = 1.

    I will try and replicate the whole installation to a localhost on my system to see if it is provider/host related.

  • Hello Seth,

    I found an older post with the title: HTTPS not working properly.
    In your reply you mention: Does your PHP install have OpenSSL built into it? That would fix this issue.

    My host supports Let's Encrypt for SSL certificates. Would this be part of the problem?
    Would it then be better (not safer) to use http instead of https?

  • Hello Seth,

    I found an older post with the title: HTTPS not working properly.
    In your reply you mention: Does your PHP install have OpenSSL built into it? That would fix this issue.

    My host supports Let's Encrypt for SSL certificates. Would this be part of the problem?
    Would it then be better (not safer) to use http instead of https?

  • edited October 2018

    Hello Seth,

    The online version is hosted with the following specs:
    Storage: unlimited (fair use)
    Data: unlimited (fair use)
    CPU: 12 cores
    Memory: 8 GB
    PHP version: 5.6

    I have tried the following:
    1. In a local copy of my collective access site with https on and openssl enabled search delivers immediate results on new items. (WAMP server 3.1.0 64bit)
    2. In my live collective access site I have set disable_out_of_process_search_indexing = 1 with https on and let's encrypt as encryption service search gives no results on new items untill manually reindixeing the search indexes
    3. In my live collective access site with http as the protocoll search gives immediate results on new items.

    Is the only available workaround using https and another security service than OPENSSL disable_out_of_process_search_indexing = 1 (wich in my case did not work) or reverting to http ?

Sign In or Register to comment.