Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Providence 1.7.6 TilePics not working

Good afternoon all,
So, I've been having some pretty good success with moving my site over from my Linux-based system to my Windows system. But, there's one problem that's been driving me crazy.

I moved all of my media from my old server to the new server. Whenever I try to load the media preview I have for my assets, I always see a message saying that it was unable to open and unable to load TileSource. I am currently running a reprocess-media with the caUtils, and I changed all of the /dev/null entries in the TilePicParser to /\$null as described in the OS specific installation instructions.

Is there something I'm missing?

Comments

  • edited September 2018

    I did notice your thread sarahs. I would want to say maybe?

    I think the issue is stemming from the tilepics being properly generated or not being parsed correctly. I think I have my external applications coded properly and everything seems to check out in the config and when I did the configuration check, everything I installed is reporting as present.

    I'm thinking it has something to do with the tilepicparser. I can see the media thumbnail on the entry page without a problem, but as I said, when I go to load the document through the site, it just spins for a bit before showing the TileSource error message.

    Attached a screenshot of the end result.

  • That's what mine does as well.

  • OK, so I'm happy to hear I'm not the only one with this issue.

    Is there anything you tried to resolve the issue? I would love to work through it and see if there's something that's being missed.

  • I tried investigating, I can write a little code, but I'm an archivist and not techinical enough to figure it out. I'm using a work around where I've bypassed the viewer and have it link directly to opening the pdf in a browser.

    I've let them know and CA is working on it. I've reminded them every so often on the chat, but they haven't had a chance to get to it yet. You might want to ask there--afterall, it may not end up being the same issue. If it is, it can't hurt to let them know that other Windows folks are out there and having the same issue.

    If you do figure it out, please let me know....

  • OK, so I did a little more poking around. I did a fresh install of a system, thinking it was something that I carried over from my past configuration. I'm not sure if this is EXACTLY what's going on, but it's something for me to go on.

    So, I found out that none of the default viewers were working. I'm guessing because it has to process the tilepics. But, something I noticed when I was going over the media_processing.conf is that there is no tilepic instance built into that config. Everything else that is an image seemed to have it. Since this particular config file hasn't been modified in over two years, it doesn't seem like that's particularly the case. But, my Ubuntu server seems to be generating tilepics without any issue. So something is supposed to be generating those tilepics, but I just don't know what it's supposed to be.

    Hyperlinking it directly to the PDF seems like a good workaround, I just don't know how to exactly code that in the config.

  • edited October 2018

    Sarahs, you were on the right track with the custom media_processing.conf. The issue I noticed is that the rule "rule_tilepic_image" generates that error message you mentioned in your thread. I ran with that idea, got the same error. So, as an experiment, I dropped the _image portion so it was just "rule_tilepic" and it generated PDF tilepics. Not an ideal situation. I'm wondering if there's a rule definition for PDFs somewhere. What's bizarre is that my Ubuntu server that I am moving off of is generating those files without any rules being defined in the mimetype.

    So I'm not sure exactly why my fix seems to be working, and I'm fairly certain this isn't the perfect fix, but it's something that I can go on. If I find any problems with it, I will let you know.

    EDIT: Viewer didn't work as I was looking at a test server, rather than my production server.

  • Could you send the pdf section of the media_processing.conf that you have working? I gave it a try and I think I'm probably misunderstanding something cause I didn't get it working....

  •     pdf = {
            QUEUE = mediaproc, 
            QUEUED_MESSAGE =  _("Document is being processed"),
            QUEUE_USING_VERSION = original,
            VERSIONS = {
                icon        = {
                    RULE = rule_icon_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },  
                iconlarge   = {
                    RULE = rule_iconlarge_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },  
                tiny        = {
                    RULE = rule_tiny_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },  
                thumbnail = {
                    RULE = rule_thumbnail_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                widethumbnail = {
                    RULE = rule_widethumbnail_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },              
                preview = {
                    RULE = rule_preview_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                preview170 = {
                    RULE = rule_preview170_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                widepreview = {
                    RULE = rule_widepreview_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                small   = {
                    RULE = rule_small_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                medium  = {
                    RULE = rule_medium_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                mediumlarge = {
                    RULE = rule_mediumlarge_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN     = <queue_threshold_in_bytes>
                },
                large   = {
                    RULE = rule_large_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN     = <queue_threshold_in_bytes>
                },
                page    = {
                    RULE = rule_page_image, VOLUME = images,
                    QUEUE_WHEN_FILE_LARGER_THAN = <queue_threshold_in_bytes>
                },
                original    = {
                    RULE = rule_original_image, VOLUME = images,
                    USE_EXTERNAL_URL_WHEN_AVAILABLE = <use_external_url_when_available>
                }
                tilepic     = {
                    RULE = rule_tilepic, VOLUME = tilepics,
                    USE_EXTERNAL_URL_WHEN_AVAILABLE = <use_external_url_when_available>
                }
            },
    

    Of course, my GraphicsMagick keeps erroring out now, so I'm not able to get any media reprocessed now, but when it was working, it was spitting out PDF _tilepic files.

    I'm thinking this has something to do with Graphicsmagick...

Sign In or Register to comment.