Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Exporting Special Characters

edited October 2018 in Troubleshooting

I have an export mapping that is sending out html and unicode character goobly-gook; for instance, "Individual & Society in Ancient Egypt" is exporting with the ampersand as "&amp:"

and "ΑΡΓΕΙΩΝ" is exporting as:

ΑΡΓΕΙΩÎ

I'm not finding anything in the documentation or forum. Anybody have any suggestions?

Thank you,
John

Comments

  • Elements that include text with special characters and unicode would need to be wrapped in CDATA otherwise XML will try to parse those characters as mark-up and break. For example: <![CDATA[Individual & Society]]>

    Depending on what data format you are exporting to, CDATA may be included by default. If it's not, and it sounds like it isnt, you should be able to manually wrap the elements in CDATA using a template.

    Hope this helps.

  • edited October 2018

    Thanks Jonathan,

    Let's see if I can get this to work (nope, the web browser keeps interpreting the "&amp:"). For the ampersand it's defaulting with the CDATA, but it looks like this:

    "<![CDATA[Individual & Society in Ancient Egypt]]>"

    A second test of the Greek characters shows them as coming out correctly now. Yay!

    I'm wondering if there is an option that I need to use to tell the exporter to send out characters as non-HTML?

    Thanks again,
    John

  • Don't know if it helps, but I'm attaching a copy of the export mapping.

  • Turns out that this might be something that I can correct when importing the records into the database reading the export feed. When I use a script to strip out the CDATA statement wrapping, it looks like the xml importer for Excel will convert the special characters correctly. If I leave the CDATA wrapper in, it imports as the "&amp:" xml special character code, not as the ampersand that I'm wanting.

Sign In or Register to comment.