Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

caUtils lacks MySQL support

CA 1.7.6
Ubuntu LTS
PHP Version 7.0.15
mysqli plugin installled
mysqlnd 5.0.12-dev - 20150407

DB-type is set to mysqli
define("CA_DB_TYPE", 'mysqli');

Did this:
bin/caUtils do-configuration-check

PHP Fatal error: Uncaught DatabaseException: Your PHP installation lacks MySQL support. Please add it and retry... in /opt/lampp/htdocs/providence/app/lib/core/Db/mysqli.php:132
Stack trace:

0 /opt/lampp/htdocs/providence/app/lib/core/Db.php(143): Db_mysqli->connect(Object(Db), Array)

1 /opt/lampp/htdocs/providence/app/lib/core/Db.php(117): Db->connect(Array)

2 /opt/lampp/htdocs/providence/app/lib/ca/ConfigurationCheck.php(82): Db->__construct()

3 /opt/lampp/htdocs/providence/app/lib/ca/Utils/CLIUtils.php(2907): ConfigurationCheck::performExpensive()

4 /opt/lampp/htdocs/providence/support/bin/caUtils(167): CLIUtils::do_configuration_check(Object(Zend_Console_Getopt))


thrown in /opt/lampp/htdocs/providence/app/lib/core/Db/mysqli.php on line 132

My installation works fine but I am unable to use caUtils for anything

Please help


  • edited November 2018

    This was fixed for me by updating php-msql

    and the setting of 'localhost' to '' in setup.php:

    if (!defined("CA_DB_HOST")) {
    define("CA_DB_HOST", '');

    which presumably forced a TCP connection instead of through sockets

  • You're command-line install of PHP doesn't have the mysql extension installed. Is it a different version (and/or install) of PHP than that which is running with your web server?

  • edited November 2018

    I am not totally sure what I had before updating with the cmd-line install. It came with the XAMPP installation. PHP-info showed the msqli-extension present before and after the update, but the update came with three new items. PHP is the same as before: PHP Version 7.0.15

    Anyway it wasn't enough. I also had to change localhost to for caUtils to work. The Ubuntu 16.04 is a virtualbox on a bridged network to a windows host

    Buy the way: can you recommend any LAMPP package for production use?

  • No, they all have problems. The best thing to do is run a real installation on a Linux or Mac OS X machine, or run Linux in VirtualBox.

  • ok Thanks

Sign In or Register to comment.