Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Problem with Providence lightbox

In Providence, when accessing an enlarged image in the Lightbox overlay, the initial enlarged images presents itself fine. However when zooming in and panning around for an even larger detail, an error is thrown, “an error occurred when trying to access /providence/index.php/Detail/GetMediaOverlay/context/id/167/representation_id/363/overlay/1: Invalid controller path." The image disappears and is replaced by a path presumably for the detail image more enlarged. Any ideas why this is happening? Thanks!

Comments

  • I am running into the exactly same problem. Debian 9, providence 1.7.6, git commit a358ebbd.
    Lightbox was working in the past (before summer?), but I cannot specify which system update or git checkout caused this issue. Any clue on your side, rsteinert?

    Felix
  • Hi Felix -- Since it is on the data entry side, I am living with it....Not ideal. Will post any findings I have when I get some time to investigate.

  • Any updates here? We are running into the same issue.

  • In your media_display.conf file check the "images" blocks and make sure no_overlay = 1 is set. Eg:

    images = {
    mimetypes = {image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, image/jp2, image/x-adobe-dng, image/bmp, image/x-bmp},
    display_version = medium,
    alt_display_version = medium,
    viewer_width = 100%, viewer_height = 100%,
    ** no_overlay = 1,**
    use_universal_viewer_for_image_list_length_at_least = 12,
    download_version = original,

        viewer = TileViewer
    },
    
  • OMG super fast @seth! Thanks! I'll try this.

    I just went in and changed the images to use the UniversalViewer instead of TileViewer, and that also solved the problem.

  • Thank you, Seth! That is great! Works really nicely. Will this setting be preserved when upgrading Providence or should we make a note of it to change manually?

  • It will be preserved when upgrading.

  • Seth, it seems that TileViewer is no mor working on v 1.7.7.

  • Works for me. You'll have to be more specific.

  • Here the details: Mirador and Universal viewers work fine. TileViewer loads but does not load the image.
    The media_display.conf is the original delivered withg v. 1.7.7 apart from switching from UniversalViewer to Mirador.

    i.e.
    media_overlay = {
    images = {
    mimetypes = {image/gif, image/jpeg, image/tiff, image/png, image/x-dcraw, image/x-psd, image/x-dpx, image/jp2, image/x-adobe-dng, image/x-dcraw, application/dicom, image/bmp, image/x-bmp},
    display_version = tilepic,
    alt_display_version = large,
    viewer_width = 100%, viewer_height = 100%,
    download_version = original,
    no_overlay = 1,

        viewer = Mirador,
        #use_universal_viewer_for_image_list_length_at_least = 3
        #use_mirador_for_image_list_length_at_least = 3
    },
    
  • Maybe v. 1.7.7 misses some code you get from previous versions?

  • Same for me, I have 1.7.6, 1.7.7 and 1.7.8 on the same server with the same setup.conf and same media folder linked by a symbolic link:

    1.7.6 work with TileViewer and the param overlay =1 mentioned above

    1.7.7 and 1.7.8 no, they work just with UniversalViewer or Mirador enabled,
    TileViewer won't display any image here

  • The tile server relies on some server environment variables that apparently are not present on all systems. There's a patch for this:

    https://github.com/collectiveaccess/providence/commit/a74a47c9b238e5af2d0e7c3efeff635021f78875

    You can apply this to your tile server code in views/apps/tilepic.php or wait for the next release.

  • Does not work for me. Where exactly should $media_root and $media_path point to?

  • edited May 2

    Finally, I solved by hard setting the variables this way in /apps/tilepic.php:
    $media_root = "/var/www/html/providence/media/mvca/";
    $script_path = "/providence/media/mvca/";

  • edited May 21

    This is better and not "hard":
    $media_root = CA_BASE_DIR."/media/".CA_APP_NAME."/";
    $script_path = substr(CA_BASE_DIR,strrpos(CA_BASE_DIR,"/"))."/media/".CA_APP_NAME."/";

    But I'm having some troubles because of "/"... I'm working to fix it.

  • edited May 21

    .

Sign In or Register to comment.