Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Object representations are not displayed anymore after migrating from mySQL ot mariaDB

After moving the database system from mySQL to mariaDB, object representations (with the image files) are not shown anymore in Providence (version 1.4) in the entry forms.

Howewer, the object representations appear to be there, since the preview images in the sidebar are visible.

When we enter new object representations with new objects, these are displayed without any problems.

With the entry forms with old problematic objects, we get a java script error in the web console:
"SyntaxError: expected expression, got ','"

We tried to reindex, but the indexing step "reload sort values" (German: "Sortierwerte neu laden") succeeds only with the first step, the second one is very slow and would take several days and we could not use the application (which is used by several institutions in Germany).

We believe that the old search index does not work properly after migrating from mySQL ot mariaDB, but we don't succeed in rebuilding the index.

Does anybody have an idea how to solve this issue?

Best,
Michael (Central and Regional Library of Berlin)

Comments

  • Maybe one of the developers can tell us where the the uncorrect code is generated in an url like

    http://hostname/collectiveaccess/index.php/editor/objects/ObjectEditor/Edit/object_id/213188

    jQuery(document).ready(function() {
    caUI.initRelationBundle('#ca_object_representationsObjectEditorForm_ca_object_representations56_rel', {
    fieldNamePrefix: 'ca_object_representationsObjectEditorForm_ca_object_representations_',
    templateValues: ['status', 'access', 'access_display', 'is_primary', 'is_primary_display', 'media', 'locale_id', 'icon', 'type', 'dimensions', 'filename', 'num_multifiles', 'metadata', 'rep_type_id', 'type_id', 'typename', 'fetched', 'label', 'rep_label', 'id', 'fetched_from','mimetype', 'center_x', 'center_y'],
    initialValues: , <=== XXX
    errors: [],
    forceNewValues: [],

    Christoph, Free Universitäty Berlin

Sign In or Register to comment.