Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

XML Data export - skipIfExpression option not working

Hi. I'm trying to export and xml hierarchy on my data on Providence 1.6.2.
What I'm tying to do is browse the ancestors of a certain object and get the preferred labels only for the ancestors of a certain type.
I tried with "context: ancestors" + "restrictToType" option but it didn't work.
What I'm trying to do now is to use the skipIfExpression option to skip all the objects with a differnt type_id from the desired one, but it doesn't seem to work either.
I attach my mappnig, maybe I'm doin' something wrong.

Thanks.

Comments

  • I'm not sure what the main problem is, but I can see there are few things wrong with your mapping. For one, ca_objects is misspelled in the Source column. Secondly, "context" must refer to a table, such as ca_objects, or ca_entities. What is "ancestors" meant to refer to? Are you referring to parent records in a hierarchical structure?

    If you are, try using ca_objects.hierarchy.preferred_labels as the "Source". The "Context" would be "ca_objects". Then, use "filterTypes" to only pull records of a specific type. Note that the value in filterTypes must refer to the actual type_id code - not the label.

    {
    "context": "ca_objects", "filterTypes":"type_id"
    }

  • Hi Jonathan.
    Thanks. It didn't work because I've seen in the documentation that the filterTypes options will be available from version 1.7.7.
    ca_objects.hierarchy.preferred_labels retrieves the preferred labels of parents objects (just like "context: ancestors" - I've seen it in an example mapping posted here on the forum and I started using it) but I still can't filter by type. I tried with a regEx too but no luck.
    Thanks anyway. i'll wait for the filterTypes option to be implemented.

Sign In or Register to comment.