Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Providence - IDNO

Dear All!

I just made a new multipart id to generate Reference number for my entities.

Here it is:

When i add the idno element to my screen, it generates irrelevant numbers for the SERIAL, for example 616 for the 10th record.

How can i fix this? Or is there any other method to use a metadata element, which will generate unique, sorted numbers for all my records?

Thanks!

Comments

  • The serialized number in the middle saves an id number one higher than the last used, so depending on the ids already in your system it may not be in the order you created the records. The object_id is the internal database id and it is sequential to the order created. It's called "CollectiveAccess id" and the code is object_id.

  • 224224
    edited November 28

    Thanks for your reply, Julia!

    I tried CollectiveAccess id (entity_id), but it shows me 36, however i have less than 10 entity records. Is it possible to give a sequential number to the existing records only?
    Another problem is that this metadata element is not working as a multipart id - i changed the corresponding part in the code (to field = entity_id), but when i open up a record for editing, it shows me only the CA id.

  • The entity_id will include any records that were created and deleted as well. That likely accounts for the difference in your number of current records vs the id. No need to change the multipart_id_numbering conf to entity_id -- that won't work. Entity_id is a field that can be added to the user interface or to a display.

    If you want total control over the number your best bet is to make the multipart id configuration set to FREE so you can enter the number by hand.

Sign In or Register to comment.