Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.

If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping

Answers may be delayed for posts that do not include sufficient information.

CONSTANT in multipart numbering not shown in editor UI

edited December 2018 in Troubleshooting

I'm trying to add a constant value to idno by object type. The problem is that the constant part is not shown in editor.

However, after saving CA complaints that constant has wrong value. So multipart setting is recognised by CA but there is some kind of problem with UI.

Here is how this is described in multipart_id_numbering.conf:

        dokumentti= {
            separator =.,

            elements = {
                object_type = {
                    type = CONSTANT,
                    description = objektityyppi,
                    width = 2,
                    value = A
                accession_number = {
                    type = SERIAL,
                    width = 6,
                    editable = 0,
                    table = ca_object_lots,
                    field = idno_stub,
                    sort_field = idno_stub_sort,    
                    description = _(Accession number)
                object_number = {
                    type = SERIAL,
                    width = 6,
                    description = _(Object number),
                    editable = 1,
                    table = ca_objects,
                    field = idno,
                    sort_field = idno_sort

What am I doing wrong here?

CA version: 1.7.6


  • Tested this further and it seems that in this scenario CONSTANT can not be the first element. If I put that last, then everything works.

Sign In or Register to comment.