Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Welcome to the CollectiveAccess support forum! Here the developers and community answer questions related to use of the software. Please include the following information in every new issue posted here:

  1. Version of the software that is used, along with browser and version

  2. If the issue pertains to Providence, Pawtucket or both

  3. What steps you’ve taken to try to resolve the issue

  4. Screenshots demonstrating the issue

  5. The relevant sections of your installation profile or configuration including the codes and settings defined for your local elements.


If your question pertains to data import or export, please also include:

  1. Data sample

  2. Your mapping


Answers may be delayed for posts that do not include sufficient information.

Displaying Rights metadata sub-elements in Pawtucket syntax

edited December 2018 in Troubleshooting

Hi,
I'm trying to display Rights holder and Rights information in Pawtucket. We have a Container metadata element code "rights" bound to "objects" with sub-elements "rightsText" and "rightsHolder". I tried adding this syntax in ca_objects_default_html.php, but it doesn't display anything:

We have the same syntax with our date info, which has a the same metadata sub-element structure and does display correctly, so I thought this should be the same. Any suggestions?


-Elizabeth

Comments

  • edited December 2018

    Hi Elizabeth,

    With repeating elements, this should be <ifcount min="1" code="ca_objects.rights.rightsText"><unit>^ca_objects.rights.rightsText</unit></ifcount>

  • Hi Sophie,
    Thanks for the reply. I tried your suggestion and it's still not displaying. I confirmed the object record I'm looking at has a value for the rightsText subelement.

  • If you output just ^ca_objects.rights.rightsText do you see anything?

  • No, I don't see anything. Is there a setting that I need to change in order to make it viewable?

  • Hi Elizabeth, If that isn't outputting anything, please doublecheck that you are viewing the correct record, that your file is being correctly saved and that data is present. At the very least something should come out of {{{^ca_objects.rights.rightsText}}} or <?php print $t_object->get('ca_objects.rights.rightsText'); ?>. If not, this isn't a display issue.

  • edited December 2018

    Hi Sophie, I figured out the issue. We have default text specified in each sub-element, which displays when you create/open an existing object record in Providence. However, it doesn't register it as a value unless I explicitly save when viewing the rights metadata of an object

Sign In or Register to comment.